aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Haupt <julian.haupt@hauptmedia.de>2018-09-30 14:42:03 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-07 22:16:10 +0200
commit0308385d1d78b81ae8fb05cb588fb91f646e3c37 (patch)
treed027fd2044b56293bad6536fc8f3fcb9f5a02b5c
parent5933958168c84d7ade94ce8bec451da2df064ead (diff)
downloadupstream-0308385d1d78b81ae8fb05cb588fb91f646e3c37.tar.gz
upstream-0308385d1d78b81ae8fb05cb588fb91f646e3c37.tar.bz2
upstream-0308385d1d78b81ae8fb05cb588fb91f646e3c37.zip
sunxi: add support for Orange Pi Zero
Signed-off-by: Julian Haupt <julian.haupt@hauptmedia.de>
-rw-r--r--package/boot/uboot-sunxi/Makefile7
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk10
2 files changed, 17 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index b3d9c1eb69..1728cc2f1e 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -150,6 +150,12 @@ define U-Boot/orangepi_r1
BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1
endef
+define U-Boot/orangepi_zero
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Orange Pi Zero (H2+)
+ BUILD_DEVICES:=sun8i-h2-plus-orangepi-zero
+endef
+
define U-Boot/orangepi_pc
BUILD_SUBTARGET:=cortexa7
NAME:=Orange Pi PC (H3)
@@ -246,6 +252,7 @@ UBOOT_TARGETS := \
nanopi_neo \
nanopi_neo_plus2 \
nanopi_neo2 \
+ orangepi_zero \
orangepi_r1 \
orangepi_pc \
orangepi_plus \
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 986b6395c4..5d6046543b 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -108,6 +108,16 @@ endef
TARGET_DEVICES += sun6i-a31-m9
+define Device/sun8i-h2-plus-orangepi-zero
+ DEVICE_TITLE:=Xunlong Orange Pi Zero
+ DEVICE_PACKAGES:=kmod-rtc-sunxi
+ SUPPORTED_DEVICES:=xunlong,orangepi-zero
+ SUNXI_DTS:=sun8i-h2-plus-orangepi-zero
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-zero
+
+
define Device/sun8i-h2-plus-orangepi-r1
DEVICE_TITLE:=Xunlong Orange Pi R1
DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152