aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-02 19:05:56 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-02 19:05:56 +0000
commit02551d388343dd7f9f0751bfebf70bbb2705d29c (patch)
treeadf7c891a45ca692913f65893d7f617ce338c745
parent0cdf133d20eccd725abb19eeb1063c16293cbc1f (diff)
downloadupstream-02551d388343dd7f9f0751bfebf70bbb2705d29c.tar.gz
upstream-02551d388343dd7f9f0751bfebf70bbb2705d29c.tar.bz2
upstream-02551d388343dd7f9f0751bfebf70bbb2705d29c.zip
ar71xx: image: simplify oneliner loader macros
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37887
-rw-r--r--target/linux/ar71xx/image/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e6149afa37..f99655edd7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -514,9 +514,7 @@ define Image/Build/UBNT
$(call sysupname,$(1),$(2))
endef
-define Image/Build/Planex/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
-endef
+Image/Build/Planex/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2) $(planex_mtdlayout),0x52000,0)
define Image/Build/Planex
[ -e "$(KDIR)/loader-$(2).gz" ]
@@ -556,9 +554,7 @@ endef
Image/Build/ALFA/initramfs=$(call MkuImageLzma/initramfs,$(2),$(3) $(4))
-define Image/Build/TPLINKOLD/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-endef
+Image/Build/TPLINKOLD/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
define Image/Build/TPLINKOLD
[ -e "$(KDIR)/loader-$(2).gz" ]
@@ -587,9 +583,7 @@ define Image/Build/TPLINKOLD/initramfs
-o $(call imgname,$(1),$(2))-initramfs-uImage.bin
endef
-define Image/Build/TPLINK/loader
- $(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
-endef
+Image/Build/TPLINK/loader=$(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
define Image/Build/TPLINK
[ -e "$(KDIR)/loader-$(2).gz" ]