aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-11-23 10:15:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-11-23 10:15:19 +0000
commitfb77d07fa25412c67137e95e61b6c06949c3046e (patch)
tree53b16e84d672ca999464e65e5513f62be4fa0822
parentba962c723f7b139c188b1b01cc4f3e23e7540bab (diff)
downloadupstream-fb77d07fa25412c67137e95e61b6c06949c3046e.tar.gz
upstream-fb77d07fa25412c67137e95e61b6c06949c3046e.tar.bz2
upstream-fb77d07fa25412c67137e95e61b6c06949c3046e.zip
Add ethernet bonding support for x86 (#856)
SVN-Revision: 5626
-rw-r--r--package/kernel/modules/network.mk11
-rw-r--r--target/linux/x86-2.6/config2
2 files changed, 12 insertions, 1 deletions
diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index c377c309e1..8bc216eda1 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -34,6 +34,17 @@ define KernelPackage/atmtcp
endef
$(eval $(call KernelPackage,atmtcp))
+define KernelPackage/bonding
+ TITLE:=Ethernet bonding driver
+ DESCRIPTION:= \
+ Kernel module for NIC bonding.
+ DEPENDS:=@LINUX_2_6_X86
+ FILES:=$(MODULES_DIR)/kernel/drivers/net/bonding/bonding.$(LINUX_KMOD_SUFFIX)
+ KCONFIG:=$(CONFIG_BONDING)
+ SUBMENU:=$(NSMENU)
+ AUTOLOAD:=$(call AutoLoad,40,bonding)
+endef
+$(eval $(call KernelPackage,bonding))
define KernelPackage/ipip
TITLE:=IP in IP encapsulation support
diff --git a/target/linux/x86-2.6/config b/target/linux/x86-2.6/config
index cd1893ec74..d186327f6f 100644
--- a/target/linux/x86-2.6/config
+++ b/target/linux/x86-2.6/config
@@ -962,7 +962,7 @@ CONFIG_BLK_DEV_SD=m
#
CONFIG_NETDEVICES=y
# CONFIG_DUMMY is not set
-# CONFIG_BONDING is not set
+CONFIG_BONDING=m
# CONFIG_EQUALIZER is not set
CONFIG_IMQ=m
# CONFIG_IMQ_BEHAVIOR_AA is not set