aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-10 16:51:07 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-12 09:39:33 +0200
commitf40f7b0fb5218d2d1e5b5b92e82d14cec30179d4 (patch)
tree2b78c4abf4fc96a4e24e938aadce62f9adb22311
parent87457ad81b0297814b3d137e77e47cbba7798881 (diff)
downloadupstream-f40f7b0fb5218d2d1e5b5b92e82d14cec30179d4.tar.gz
upstream-f40f7b0fb5218d2d1e5b5b92e82d14cec30179d4.tar.bz2
upstream-f40f7b0fb5218d2d1e5b5b92e82d14cec30179d4.zip
kernel: bump 4.14 to 4.14.133
Refreshed all patches. Fixes: - CVE-2019-3900 Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 63995560b2..3c22ce0dce 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-4.9 = .180
-LINUX_VERSION-4.14 = .132
+LINUX_VERSION-4.14 = .133
LINUX_VERSION-4.19 = .48
LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
-LINUX_KERNEL_HASH-4.14.132 = da86f39a722da656fce4e2685223093b5d5f4db94046fcd79e492428a82ff330
+LINUX_KERNEL_HASH-4.14.133 = be9844e534d28db51a81672cdeb8e430a47f4c91379c06cd431f0b8a1c79b700
LINUX_KERNEL_HASH-4.19.48 = 01d0db4f10cc8e384241a605e29413e32c442aa6853c116877538b07c16893fa
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch b/target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch
index 3de77b1afd..8dc8664c92 100644
--- a/target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch
+++ b/target/linux/brcm47xx/patches-4.14/159-cpu_fixes.patch
@@ -458,7 +458,7 @@
/*
--- a/arch/mips/mm/tlbex.c
+++ b/arch/mips/mm/tlbex.c
-@@ -971,6 +971,9 @@ void build_get_pgde32(u32 **p, unsigned
+@@ -976,6 +976,9 @@ void build_get_pgde32(u32 **p, unsigned
uasm_i_srl(p, ptr, ptr, SMP_CPUID_PTRSHIFT);
uasm_i_addu(p, ptr, tmp, ptr);
#else
@@ -468,7 +468,7 @@
UASM_i_LA_mostly(p, ptr, pgdc);
#endif
uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -1331,6 +1334,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1337,6 +1340,9 @@ static void build_r4000_tlb_refill_handl
#ifdef CONFIG_64BIT
build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
#else
@@ -478,7 +478,7 @@
build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
#endif
-@@ -1342,6 +1348,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1348,6 +1354,9 @@ static void build_r4000_tlb_refill_handl
build_update_entries(&p, K0, K1);
build_tlb_write_entry(&p, &l, &r, tlb_random);
uasm_l_leave(&l, p);
@@ -488,7 +488,7 @@
uasm_i_eret(&p); /* return from trap */
}
#ifdef CONFIG_MIPS_HUGE_TLB_SUPPORT
-@@ -2046,6 +2055,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -2057,6 +2066,9 @@ build_r4000_tlbchange_handler_head(u32 *
#ifdef CONFIG_64BIT
build_get_pmde64(p, l, r, wr.r1, wr.r2); /* get pmd in ptr */
#else
@@ -498,7 +498,7 @@
build_get_pgde32(p, wr.r1, wr.r2); /* get pgd in ptr */
#endif
-@@ -2092,6 +2104,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -2103,6 +2115,9 @@ build_r4000_tlbchange_handler_tail(u32 *
build_tlb_write_entry(p, l, r, tlb_indexed);
uasm_l_leave(l, *p);
build_restore_work_registers(p);