aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
commitf1da5431bb3e440f3d1337a8ec08cc09611a1550 (patch)
tree1f72522059329319cd185e32f50190e87f48969a
parent8b689d039739629ec24c86e47e4aa32e5b80f2bb (diff)
downloadupstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.tar.gz
upstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.tar.bz2
upstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.zip
build variants: only build opkg packages for the requested build variant (or any if no variant was specified for the package)
SVN-Revision: 18464
-rw-r--r--include/package-ipkg.mk2
-rw-r--r--package/hostapd/Makefile9
2 files changed, 4 insertions, 7 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index bd4e28ce35..1ddd80a8dc 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -36,6 +36,7 @@ ifeq ($(DUMP),)
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
+ ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
ifdef Package/$(1)/install
ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
compile: $$(IPKG_$(1)) $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
@@ -49,6 +50,7 @@ ifeq ($(DUMP),)
@echo "WARNING: skipping $(1) -- package not selected"
endif
endif
+ endif
IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 5e10ea27b9..bb497fec3b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -108,7 +108,7 @@ define Build/Compile
hostapd hostapd_cli
endef
-define Package/InstallTemplate
+define Package/hostapd/install
$(INSTALL_DIR) $(1)/etc/hotplug.d/net
$(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
$(INSTALL_DIR) $(1)/lib/wifi
@@ -116,12 +116,7 @@ define Package/InstallTemplate
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
endef
-
-ifeq ($(BUILD_VARIANT),full)
- Package/hostapd/install = $(Package/InstallTemplate)
-else
- Package/hostapd-mini/install = $(Package/InstallTemplate)
-endif
+Package/hostapd-mini/install = $(Package/hostapd/install)
define Package/hostapd-utils/install
$(INSTALL_DIR) $(1)/usr/sbin