aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarko Ratkaj <marko.ratkaj@sartura.hr>2017-04-06 20:13:31 +0200
committerLuka Perkov <luka.perkov@sartura.hr>2017-05-14 00:34:03 +0200
commitee1cee2cac67108194f1496c29fead90afff1763 (patch)
tree016b1247a7d94c46d2580bd19883fda0de2b1b36
parentf564fcc6bfb7bae4ca7768f8b30f5348fb472d97 (diff)
downloadupstream-ee1cee2cac67108194f1496c29fead90afff1763.tar.gz
upstream-ee1cee2cac67108194f1496c29fead90afff1763.tar.bz2
upstream-ee1cee2cac67108194f1496c29fead90afff1763.zip
mvebu: add ClearFog Base support
Add support for SolidRun ClearFog Base board. The base model is a smaller version of ClearFog Pro without the DSA switch, replacing it with a second copper gigabit port, and only one PCIe socket. Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
-rw-r--r--package/boot/uboot-mvebu/Makefile2
-rwxr-xr-xtarget/linux/mvebu/base-files/etc/board.d/02_network3
-rwxr-xr-xtarget/linux/mvebu/base-files/lib/mvebu.sh3
-rwxr-xr-xtarget/linux/mvebu/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/mvebu/image/Makefile20
-rw-r--r--target/linux/mvebu/image/cfbase-boot.script7
6 files changed, 37 insertions, 1 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 1f2361caf0..a20c4b4f2d 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -23,7 +23,7 @@ endef
define U-Boot/clearfog
NAME:=SolidRun ClearFog A1
- BUILD_DEVICES:=armada-388-clearfog-pro
+ BUILD_DEVICES:=armada-388-clearfog-base armada-388-clearfog-pro
UBOOT_IMAGE:=u-boot-spl.kwb
endef
diff --git a/target/linux/mvebu/base-files/etc/board.d/02_network b/target/linux/mvebu/base-files/etc/board.d/02_network
index 68231e004a..aea6224891 100755
--- a/target/linux/mvebu/base-files/etc/board.d/02_network
+++ b/target/linux/mvebu/base-files/etc/board.d/02_network
@@ -33,6 +33,9 @@ armada-388-clearfog-pro)
ucidef_add_switch "switch0" \
"0:lan:5" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5u@eth0" "6:lan:6"
;;
+armada-388-clearfog-base)
+ ucidef_set_interfaces_lan_wan "eth0" "eth1"
+ ;;
*)
ucidef_set_interface_lan "eth0"
;;
diff --git a/target/linux/mvebu/base-files/lib/mvebu.sh b/target/linux/mvebu/base-files/lib/mvebu.sh
index 0fcc82d034..ecf3d44848 100755
--- a/target/linux/mvebu/base-files/lib/mvebu.sh
+++ b/target/linux/mvebu/base-files/lib/mvebu.sh
@@ -56,6 +56,9 @@ mvebu_board_detect() {
*"SolidRun Clearfog Pro A1")
name="armada-388-clearfog-pro"
;;
+ *"SolidRun Clearfog Base A1")
+ name="armada-388-clearfog-base"
+ ;;
esac
[ -z "$name" ] && name="unknown"
diff --git a/target/linux/mvebu/base-files/lib/upgrade/platform.sh b/target/linux/mvebu/base-files/lib/upgrade/platform.sh
index 6db25448d6..12e5bdcf7c 100755
--- a/target/linux/mvebu/base-files/lib/upgrade/platform.sh
+++ b/target/linux/mvebu/base-files/lib/upgrade/platform.sh
@@ -22,6 +22,9 @@ platform_do_upgrade() {
armada-388-clearfog-pro)
platform_do_upgrade_clearfog "$ARGV"
;;
+ armada-388-clearfog-base)
+ platform_do_upgrade_clearfog "$ARGV"
+ ;;
*)
default_do_upgrade "$ARGV"
;;
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index dcbf4a67b3..f112bb9a1e 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -28,6 +28,11 @@ define Build/boot-scr-cfpro
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
endef
+define Build/boot-scr-cfbase
+ rm -f $@.bootscript
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
+endef
+
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot 16384
@@ -182,6 +187,21 @@ define Device/armada-388-clearfog-pro
endef
TARGET_DEVICES += armada-388-clearfog-pro
+define Device/armada-388-clearfog-base
+ KERNEL_INSTALL := 1
+ KERNEL := dtb | kernel-bin
+ DEVICE_TITLE := SolidRun ClearFog Base
+ DEVICE_PACKAGES := \
+ kmod-nls-cp437 kmod-nls-iso8859-1 \
+ mkf2fs e2fsprogs kmod-fs-vfat kmod-fuse kmod-fs-f2fs \
+ kmod-ata-core kmod-ata-ahci kmod-ata-marvell-sata kmod-scsi-core kmod-scsi-generic \
+ kmod-button-hotplug kmod-gpio-button-hotplug
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
+ IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+endef
+TARGET_DEVICES += armada-388-clearfog-base
+
define Device/globalscale-mirabox
$(Device/NAND-512K)
DEVICE_DTS := armada-370-mirabox
diff --git a/target/linux/mvebu/image/cfbase-boot.script b/target/linux/mvebu/image/cfbase-boot.script
new file mode 100644
index 0000000000..3043d261ce
--- /dev/null
+++ b/target/linux/mvebu/image/cfbase-boot.script
@@ -0,0 +1,7 @@
+setenv bootargs console=ttyS0,115200n8 root=/dev/mmcblk0p2 rootfstype=squashfs rootwait overlay=/dev/mmcblk0p3
+setenv fdt_high 0x07a12000
+
+fatload mmc 0:1 0x02000000 zImage
+fatload mmc 0:1 0x05F00000 armada-388-clearfog-base.dtb
+
+bootz 0x02000000 - 0x05F00000