aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2019-11-07 14:31:29 +0100
committerJo-Philipp Wich <jo@mein.io>2020-03-04 09:16:43 +0100
commite7f1313bbbf44e529e5de40045b191e026af6b7b (patch)
tree0e340ac0c379b04f1bf76dabb8c1d0de20479a14
parentf6f0cd54a2e5bef1c9c7ea9899badc8e2c93d58c (diff)
downloadupstream-e7f1313bbbf44e529e5de40045b191e026af6b7b.tar.gz
upstream-e7f1313bbbf44e529e5de40045b191e026af6b7b.tar.bz2
upstream-e7f1313bbbf44e529e5de40045b191e026af6b7b.zip
rpcd: add respawn param
The rpcd service is an important service, but if the service stops working for any reason, no one will ever respawn that service. With this commit, the procd service will monitor if the rpcd service is running. If the rpcd service has crashed, then procd respawns the rpcd service. Signed-off-by: Florian Eckert <fe@dev.tdt.de> (cherry picked from commit 432ec292ccc8b634facacbd018d08947d204225a)
-rw-r--r--package/system/rpcd/Makefile2
-rwxr-xr-xpackage/system/rpcd/files/rpcd.init1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 853554b5a0..653c859ba1 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
diff --git a/package/system/rpcd/files/rpcd.init b/package/system/rpcd/files/rpcd.init
index 77ebcbe6cb..b1061b906c 100755
--- a/package/system/rpcd/files/rpcd.init
+++ b/package/system/rpcd/files/rpcd.init
@@ -12,6 +12,7 @@ start_service() {
procd_open_instance
procd_set_param command "$PROG" ${socket:+-s "$socket"} ${timeout:+-t "$timeout"}
+ procd_set_param respawn ${respawn_retry:-0}
procd_close_instance
}