aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-03-11 18:50:42 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-03-11 22:00:26 +0100
commitdb91418766562fde7da468a19c87f25bc8aad8a0 (patch)
treea9c3e67e7bfe940c88c75cdbad25528918be8ae7
parent82dbcd8bf2b472a962aa002d9c5cc2542608035a (diff)
downloadupstream-db91418766562fde7da468a19c87f25bc8aad8a0.tar.gz
upstream-db91418766562fde7da468a19c87f25bc8aad8a0.tar.bz2
upstream-db91418766562fde7da468a19c87f25bc8aad8a0.zip
ath79: add support for TP-Link RE350K v1
TP-Link RE350K v1 (FCC ID: TE7RE350K) is a wall-plug AC1200 Wi-Fi range extender with 'Kasa Smart' support. Device is based on Qualcomm/Atheros QCA9558 + QCA9882 + AR8035 platform and is available only on US market. Specification: - 720/600/200 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of flash (SPI NOR) - 1x 1 Gbps Ethernet (AR8035) - 2T2R 2.4 GHz (QCA9558), with ext. PA (SE2565T) and LNA (SKY65971-11) - 2T2R 5 GHz (QCA9882), with ext. PA (SE5003L1-R) and LNA (SKY65981-11) - 2x U.FL connector on PCB - 2x dual-band PCB antennas - 1x LED, 2x dual-color LED (all driven by GPIO) - 3x button (app config, led, reset) - 1x mechanical on/off slide switch - 1x UART (4-pin, 2.54 mm pitch) header on PCB - 1x JTAG (8-pin, 1.27 mm pitch) header on PCB Flash instruction: Use 'factory' image directly in vendor GUI (default IP: 192.168.0.254, default credentials: admin/admin). Warning: This device does not include any kind of recovery mechanism in U-Boot. Vendor firmware access: You can access vendor firmware over serial (RX line requires jumper resistor in R306 place, near XTAL) with: root/sohoadmin credentials. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata4
-rw-r--r--target/linux/ath79/dts/qca9558_tplink_re350k-v1.dts173
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk16
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c32
5 files changed, 226 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 76a1ffba40..e66eb938fd 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -18,6 +18,7 @@ ath79_setup_interfaces()
pcs,cap324|\
pisen,wmm003n|\
pqi,air-pen|\
+ tplink,re350k-v1|\
tplink,re450-v2|\
tplink,tl-mr10u|\
tplink,tl-mr3020-v1|\
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 53128cad65..501a475571 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -141,6 +141,10 @@ case "$FIRMWARE" in
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) -1)
;;
+ tplink,re350k-v1)
+ ath10kcal_extract "art" 20480 2116
+ ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +2)
+ ;;
ubnt,unifiac-lite|\
ubnt,unifiac-mesh|\
ubnt,unifiac-mesh-pro|\
diff --git a/target/linux/ath79/dts/qca9558_tplink_re350k-v1.dts b/target/linux/ath79/dts/qca9558_tplink_re350k-v1.dts
new file mode 100644
index 0000000000..056b513d7e
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_tplink_re350k-v1.dts
@@ -0,0 +1,173 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+ model = "TP-Link RE350K v1";
+ compatible = "tplink,re350k-v1", "qca,qca9558";
+
+ aliases {
+ led-boot = &power;
+ led-failsafe = &power;
+ led-running = &power;
+ led-upgrade = &power;
+ mdio-gpio0 = &mdio2;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200n8";
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ app-config {
+ label = "app-config";
+ linux,code = <BTN_0>;
+ gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ led {
+ label = "led";
+ linux,code = <BTN_1>;
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ power: power {
+ label = "tp-link:green:power";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wlan2g-green {
+ label = "tp-link:green:wlan2g";
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wlan2g-red {
+ label = "tp-link:red:wlan2g";
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan5g-green {
+ label = "tp-link:green:wlan5g";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g-red {
+ label = "tp-link:red:wlan5g";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ mdio2: mdio {
+ compatible = "virtual,mdio-gpio";
+
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ gpios = <&gpio 23 GPIO_ACTIVE_HIGH>,
+ <&gpio 18 GPIO_ACTIVE_HIGH>;
+
+ phy0: ethernet-phy@4 {
+ reg = <4>;
+
+ phy-mode = "rgmii-rxid";
+ at803x-disable-smarteee;
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ mtd-mac-address = <&config 0x10008>;
+ pll-data = <0x9e000000 0x80000101 0x80001313>;
+ phy-handle = <&phy0>;
+
+ gmac-config {
+ device = <&gmac>;
+
+ rxdv-delay = <2>;
+ rxd-delay = <2>;
+ txen-delay = <0>;
+ txd-delay = <0>;
+ rgmii-enabled = <1>;
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x020000 0xd70000>;
+ };
+
+ config: partition@d90000 {
+ label = "config";
+ reg = <0xd90000 0x260000>;
+ read-only;
+ };
+
+ art: partition@ff0000 {
+ label = "art";
+ reg = <0xff0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&config 0x10008>;
+};
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 5933988632..e82a5a3073 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -109,6 +109,22 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_re350k-v1
+ $(Device/tplink)
+ ATH_SOC := qca9558
+ IMAGE_SIZE := 13760k
+ DEVICE_TITLE := TP-Link RE350K v1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := RE350K-V1
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
+ check-size $$$$(IMAGE_SIZE) | append-metadata
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += tplink_re350k-v1
+
define Device/tplink_re450-v2
$(Device/tplink)
ATH_SOC := qca9563
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 075cd8a7ed..c2aa2962f6 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -1144,6 +1144,38 @@ static struct device_info boards[] = {
.last_sysupgrade_partition = "file-system"
},
+ /** Firmware layout for the RE350K v1 */
+ {
+ .id = "RE350K-V1",
+ .vendor = "",
+ .support_list =
+ "SupportList:\n"
+ "{product_name:RE350K,product_ver:1.0.0,special_id:00000000,product_region:US}\n",
+ .support_trail = '\x00',
+ .soft_ver = NULL,
+
+ /** We're using a dynamic kernel/rootfs split here */
+ .partitions = {
+ {"fs-uboot", 0x00000, 0x20000},
+ {"firmware", 0x20000, 0xd70000},
+ {"partition-table", 0xd90000, 0x02000},
+ {"default-mac", 0xda0000, 0x00020},
+ {"pin", 0xda0100, 0x00020},
+ {"product-info", 0xda1100, 0x01000},
+ {"soft-version", 0xdb0000, 0x01000},
+ {"support-list", 0xdb1000, 0x01000},
+ {"profile", 0xdb2000, 0x08000},
+ {"user-config", 0xdc0000, 0x10000},
+ {"default-config", 0xdd0000, 0x10000},
+ {"device-id", 0xde0000, 0x00108},
+ {"radio", 0xff0000, 0x10000},
+ {NULL, 0, 0}
+ },
+
+ .first_sysupgrade_partition = "os-image",
+ .last_sysupgrade_partition = "file-system"
+ },
+
/** Firmware layout for the RE355 */
{
.id = "RE355",