aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Haab <dan.haab@legrand.com>2020-02-05 10:37:44 -0700
committerRafał Miłecki <rafal@milecki.pl>2020-02-07 12:09:27 +0100
commitcff3795450b77d4ee40a0079505375fc50c4c21a (patch)
tree412a3c444bea8058461d09743d45d3c631dba908
parentcf2b04285591ba319d5197e0df5dade34c68dd97 (diff)
downloadupstream-cff3795450b77d4ee40a0079505375fc50c4c21a.tar.gz
upstream-cff3795450b77d4ee40a0079505375fc50c4c21a.tar.bz2
upstream-cff3795450b77d4ee40a0079505375fc50c4c21a.zip
bcm53xx: build images for Luxul ABR-4500 and XBR-4500 routers
Luxul ABR-4500 and XBR-4500 devices are wired routers with 5 Ethernet ports and 1 USB 3.0 port. Flashing requires using Luxul firmware 6.4.0 or newer and uploading firmware using "Firmware Update" web UI page. Signed-off-by: Dan Haab <dan.haab@legrand.com> (cherry picked from commit 1d47f81581bcd476487e5b29314602167a843b99) [rmilecki: use DEVICE_TITLE for 19.07] Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
-rwxr-xr-xtarget/linux/bcm53xx/base-files/etc/board.d/02_network7
-rw-r--r--target/linux/bcm53xx/image/Makefile29
2 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/base-files/etc/board.d/02_network b/target/linux/bcm53xx/base-files/etc/board.d/02_network
index 8c9e8b3f3f..9fd26e72f4 100755
--- a/target/linux/bcm53xx/base-files/etc/board.d/02_network
+++ b/target/linux/bcm53xx/base-files/etc/board.d/02_network
@@ -24,6 +24,13 @@ buffalo,wzr-1750dhp)
board_config_flush
exit 0
;;
+luxul,abr-4500-v1|\
+luxul,xbr-4500-v1)
+ ucidef_add_switch "switch0" \
+ "0:wan" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5@eth0"
+ board_config_flush
+ exit 0
+ ;;
phicomm,k3)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:wan" "5@eth0"
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index fc18a96232..4f18a9c0a8 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -83,6 +83,13 @@ define Build/asus-trx
mv $@.new $@
endef
+define Build/luxul-lxl
+ $(STAGING_DIR_HOST)/bin/lxlfw create $@.new \
+ -i $@ \
+ -b $(LUXUL_BOARD)
+ mv $@.new $@
+endef
+
define Build/seama-nand
# Seama entity
$(STAGING_DIR_HOST)/bin/oseama \
@@ -102,6 +109,7 @@ endef
DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION TPLINK_BOARD
DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
+DEVICE_VARS += LUXUL_BOARD
IEEE8021X := wpad-basic
B43 := $(IEEE8021X) kmod-b43
@@ -249,6 +257,27 @@ define Device/linksys-ea9500
endef
# TARGET_DEVICES += linksys-ea9500
+define Device/luxul
+ IMAGES := lxl
+ IMAGE/lxl := append-ubi | trx-nand | luxul-lxl
+endef
+
+define Device/luxul-abr-4500
+ $(Device/luxul)
+ DEVICE_TITLE := Luxul ABR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := ABR-4500
+endef
+TARGET_DEVICES += luxul-abr-4500
+
+define Device/luxul-xbr-4500
+ $(Device/luxul)
+ DEVICE_TITLE := Luxul XBR-4500
+ DEVICE_PACKAGES := $(USB3_PACKAGES)
+ LUXUL_BOARD := XBR-4500
+endef
+TARGET_DEVICES += luxul-xbr-4500
+
define Device/netgear
IMAGES := chk
IMAGE/chk := append-ubi | trx-nand | netgear-chk