aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2019-06-10 22:16:09 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-06-11 01:53:08 +0200
commitb344ca9ca68322a023414e7e38ddd4d81aa8d378 (patch)
tree6bc9bb0653bd3f345e970f4c77cbc2b44d382844
parentc53f62b1113459ade21f9540a41db66570097a7f (diff)
downloadupstream-b344ca9ca68322a023414e7e38ddd4d81aa8d378.tar.gz
upstream-b344ca9ca68322a023414e7e38ddd4d81aa8d378.tar.bz2
upstream-b344ca9ca68322a023414e7e38ddd4d81aa8d378.zip
OpenWrt v19.07: set branch defaults
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--feeds.conf.default13
-rw-r--r--include/version.mk4
-rw-r--r--package/base-files/image-config.in2
3 files changed, 7 insertions, 12 deletions
diff --git a/feeds.conf.default b/feeds.conf.default
index da6c665624..42c2b0ba3b 100644
--- a/feeds.conf.default
+++ b/feeds.conf.default
@@ -1,9 +1,4 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git management https://github.com/openwrt-management/packages.git
-#src-git oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-19.07
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-19.07
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-19.07
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-19.07
diff --git a/include/version.mk b/include/version.mk
index 7d3c1ad640..db0167d811 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -26,13 +26,13 @@ PKG_CONFIG_DEPENDS += \
sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),19.07-SNAPSHOT)
VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/releases/19.07-SNAPSHOT)
VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 3432db525a..560b66dfc9 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -183,7 +183,7 @@ if VERSIONOPT
config VERSION_REPO
string
prompt "Release repository"
- default "http://downloads.openwrt.org/snapshots"
+ default "http://downloads.openwrt.org/releases/19.07-SNAPSHOT"
help
This is the repository address embedded in the image, it defaults
to the trunk snapshot repo; the url may contain the following placeholders: