aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-22 21:25:07 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-22 21:25:07 +0100
commitb2660e67f0fb9f3398b871ad1fef5725e1b5d7d2 (patch)
treea905d6d93df1b72606750c0b8b6e5c19f807fefa
parent21bf718b8c3b0fe1f13807aa5db16a2fb4f48120 (diff)
downloadupstream-b2660e67f0fb9f3398b871ad1fef5725e1b5d7d2.tar.gz
upstream-b2660e67f0fb9f3398b871ad1fef5725e1b5d7d2.tar.bz2
upstream-b2660e67f0fb9f3398b871ad1fef5725e1b5d7d2.zip
Revert "ath79: add support for Ubiquiti NanoStation Loco M (XW)"
This reverts commit 21bf718b8c3b0fe1f13807aa5db16a2fb4f48120. Until the mdio-reset is solved, this is not ready for stable release. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts29
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk8
4 files changed, 0 insertions, 39 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index dd483c0526..f600c6f779 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -201,7 +201,6 @@ tplink,tl-wr842n-v2)
ubnt,bullet-m|\
ubnt,bullet-m-xw|\
ubnt,nanostation-loco-m|\
-ubnt,nanostation-loco-m-xw|\
ubnt,nanostation-m|\
ubnt,nanostation-m-xw|\
ubnt,picostation-m|\
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index c985a823c4..3df6fde229 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -39,7 +39,6 @@ ath79_setup_interfaces()
ubnt,nanobeam-ac|\
ubnt,nanostation-ac-loco|\
ubnt,nanostation-loco-m|\
- ubnt,nanostation-loco-m-xw|\
ubnt,picostation-m|\
ubnt,rocket-m|\
ubnt,unifiac-lite|\
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts
deleted file mode 100644
index 8fb05eda24..0000000000
--- a/target/linux/ath79/dts/ar9342_ubnt_nanostation-loco-m-xw.dts
+++ /dev/null
@@ -1,29 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9342_ubnt_xw.dtsi"
-
-/ {
- compatible = "ubnt,nanostation-loco-m-xw", "ubnt,xw", "qca,ar9342";
- model = "Ubiquiti Nanostation Loco M (XW)";
-};
-
-&mdio0 {
- status = "okay";
-
- phy-mask = <0x1>;
-
- phy1: ethernet-phy@1 {
- reg = <1>;
- phy-mode = "mii";
- };
-};
-
-&eth0 {
- status = "okay";
-
- phy-handle = <&phy1>;
-};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index f34ffa1612..1ae16554bc 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -125,14 +125,6 @@ define Device/ubnt_nanostation-loco-m
endef
TARGET_DEVICES += ubnt_nanostation-loco-m
-define Device/ubnt_nanostation-loco-m-xw
- $(Device/ubnt-xw)
- DEVICE_TITLE := Ubiquiti Nanostation Loco M (XW)
- DEVICE_PACKAGES += rssileds
- SUPPORTED_DEVICES += loco-m-xw
-endef
-TARGET_DEVICES += ubnt_nanostation-loco-m-xw
-
define Device/ubnt_nanostation-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Nanostation M