aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2020-01-20 12:04:33 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-01-20 13:43:56 +0100
commitae953449f2f6807174a2c000b9fc5a31b46f1798 (patch)
treefbac9755b499aee45bb590e1f34704d3b3e11aa4
parent945db9fb015ac636e92282780a22f65f0eefe98a (diff)
downloadupstream-ae953449f2f6807174a2c000b9fc5a31b46f1798.tar.gz
upstream-ae953449f2f6807174a2c000b9fc5a31b46f1798.tar.bz2
upstream-ae953449f2f6807174a2c000b9fc5a31b46f1798.zip
kernel: bump 4.14 to 4.14.166
Refreshed all patches. Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch2
-rw-r--r--target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index f03d6d4705..c3890d4910 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .165
+LINUX_VERSION-4.14 = .166
-LINUX_KERNEL_HASH-4.14.165 = b0aeb52386404f4e3546f93cf63c857025fc3117ff1b56e3499aa1eae6e088c7
+LINUX_KERNEL_HASH-4.14.166 = 8bb2bf811a2092933a2386a4e679cd0c88de979c10fbb463d8142add4e577c00
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch b/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
index 099b6031b5..59ed130567 100644
--- a/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
@@ -285,7 +285,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
#define PAGE_NONE __pgprot(((_PAGE_DEFAULT) & ~PTE_VALID) | PTE_PROT_NONE | PTE_RDONLY | PTE_NG | PTE_PXN | PTE_UXN)
--- a/arch/arm64/include/asm/pgtable.h
+++ b/arch/arm64/include/asm/pgtable.h
-@@ -356,6 +356,11 @@ static inline int pmd_protnone(pmd_t pmd
+@@ -357,6 +357,11 @@ static inline int pmd_protnone(pmd_t pmd
__pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_DEVICE_nGnRnE) | PTE_PXN | PTE_UXN)
#define pgprot_writecombine(prot) \
__pgprot_modify(prot, PTE_ATTRINDX_MASK, PTE_ATTRINDX(MT_NORMAL_NC) | PTE_PXN | PTE_UXN)
diff --git a/target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch b/target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch
index 8b845dd715..931e09a9fa 100644
--- a/target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/821-smmu-support-layerscape.patch
@@ -123,7 +123,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
static struct kset *iommu_group_kset;
static DEFINE_IDA(iommu_group_ida);
-@@ -989,6 +990,26 @@ struct iommu_group *pci_device_group(str
+@@ -990,6 +991,26 @@ struct iommu_group *pci_device_group(str
return iommu_group_alloc();
}