aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-07-04 13:17:02 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-07-05 22:29:27 +0200
commitacd2497cfbd62a3237b8a338cfa2316499572e50 (patch)
tree672b804d518686277eac113edd83081b63e8d79c
parent1b990513997481f8e5a9f2200c977ab4345fb787 (diff)
downloadupstream-acd2497cfbd62a3237b8a338cfa2316499572e50.tar.gz
upstream-acd2497cfbd62a3237b8a338cfa2316499572e50.tar.bz2
upstream-acd2497cfbd62a3237b8a338cfa2316499572e50.zip
mpc85xx: Use gzip compressed kernel on HiveAP-330
After commit 1e41de2f48 ("mpc85xx: convert TL-WDR4900 v1 to simpleImage") XZ compression of zImage was enabled. This change exposed a problem with the HiveAP-330 images, which was fixed by foregoing the compression on the kernel altogether with commit 98089bb8ba8 ("mpc85xx: Use uncompressed kernel on the HiveAP-330"). This patch adds back the gzip compression of the kernel image by utilizing the generic OpenWRT uImage method instead of relying on the PowerPC bootwrapper script that did it previously. Compile-tested: p1020/hiveap-330 Tested-by: Chris Blake <chrisrblake93@gmail.com> [run-tested] Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [filled in even more text]
-rw-r--r--target/linux/mpc85xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mpc85xx/image/Makefile b/target/linux/mpc85xx/image/Makefile
index c582d7a592..c2ddcb32c5 100644
--- a/target/linux/mpc85xx/image/Makefile
+++ b/target/linux/mpc85xx/image/Makefile
@@ -85,7 +85,7 @@ define Device/hiveap-330
DEVICE_TITLE := Aerohive HiveAP-330
DEVICE_PACKAGES := kmod-tpm-i2c-atmel
BLOCKSIZE := 128k
- KERNEL := kernel-bin | uImage none
+ KERNEL := kernel-bin | gzip | uImage gzip
KERNEL_SIZE := 8m
KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs | uImage none
SUPPORTED_DEVICES := aerohive,hiveap-330