aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOzgur Can Leonard <ozgurcan@gmail.com>2019-08-02 21:55:41 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 16:08:16 +0100
commita885f7d3d00f1d2332dda355828ac22f44beef13 (patch)
treeca03bf2e0cfcca302b607702aba449eebe48b93f
parent67c8e586c879e3f9386007ac6389ee21f9589572 (diff)
downloadupstream-a885f7d3d00f1d2332dda355828ac22f44beef13.tar.gz
upstream-a885f7d3d00f1d2332dda355828ac22f44beef13.tar.bz2
upstream-a885f7d3d00f1d2332dda355828ac22f44beef13.zip
ramips: add kmod-mt7615e to Xiaomi Mi Router 3 Pro images
Now that the mt76/mt7615e driver is in Openwrt, might as well use it. Signed-off-by: Ozgur Can Leonard <ozgurcan@gmail.com> (cherry picked from commit d7c082ba4f7de97b3708d1f4a064954ffc774778)
-rw-r--r--target/linux/ramips/dts/MIR3P.dts5
-rw-r--r--target/linux/ramips/image/mt7621.mk3
2 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/ramips/dts/MIR3P.dts b/target/linux/ramips/dts/MIR3P.dts
index cd929e5e33..ff250136f2 100644
--- a/target/linux/ramips/dts/MIR3P.dts
+++ b/target/linux/ramips/dts/MIR3P.dts
@@ -161,15 +161,16 @@
&pcie0 {
wifi@0,0 {
- compatible = "pci14c3,7615";
+ compatible = "mediatek,mt76";
reg = <0x0000 0 0 0 0>;
mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
};
};
&pcie1 {
wifi@0,0 {
- compatible = "pci14c3,7615";
+ compatible = "mediatek,mt76";
reg = <0x0000 0 0 0 0>;
mediatek,mtd-eeprom = <&factory 0x8000>;
ieee80211-freq-limit = <5000000 6000000>;
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 5001a5da82..53a264f527 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -266,7 +266,8 @@ define Device/xiaomi_mir3p
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
DEVICE_PACKAGES := \
- kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic uboot-envtools
+ kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
+ uboot-envtools
endef
TARGET_DEVICES += xiaomi_mir3p