aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-29 13:52:04 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-07-31 16:56:19 +0200
commit4fd61b6220a7a25f2284731688eafb0495643d0e (patch)
tree075f4d929a2ccdfe253f2e96f5abf332501b3c18
parent8c57d88fcc8dbdd4b0ee68b9f842fe35a2f188ae (diff)
downloadupstream-4fd61b6220a7a25f2284731688eafb0495643d0e.tar.gz
upstream-4fd61b6220a7a25f2284731688eafb0495643d0e.tar.bz2
upstream-4fd61b6220a7a25f2284731688eafb0495643d0e.zip
kernel: bump 4.14 to 4.14.134
Refreshed all patches. Remove upstreamed: - 049-v4.20-mips-remove-superfluous-check-for-linux.patch Fixes: - CVE-2019-3846 - CVE-2019-3900 Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0132-mcp2515-Use-DT-supplied-interrupt-flags.patch2
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch2
-rw-r--r--target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch2
-rw-r--r--target/linux/generic/backport-4.14/049-v4.20-mips-remove-superfluous-check-for-linux.patch47
5 files changed, 5 insertions, 52 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index d7ed7ba0b3..535aed640d 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .133
+LINUX_VERSION-4.14 = .134
-LINUX_KERNEL_HASH-4.14.133 = be9844e534d28db51a81672cdeb8e430a47f4c91379c06cd431f0b8a1c79b700
+LINUX_KERNEL_HASH-4.14.134 = 0b21e7b5effd92303a551b5be2380c9703d6fb87cfe5189fe0d795cc73903d2d
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.14/950-0132-mcp2515-Use-DT-supplied-interrupt-flags.patch b/target/linux/brcm2708/patches-4.14/950-0132-mcp2515-Use-DT-supplied-interrupt-flags.patch
index 31942750c1..bb87c97c6c 100644
--- a/target/linux/brcm2708/patches-4.14/950-0132-mcp2515-Use-DT-supplied-interrupt-flags.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0132-mcp2515-Use-DT-supplied-interrupt-flags.patch
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
--- a/drivers/net/can/spi/mcp251x.c
+++ b/drivers/net/can/spi/mcp251x.c
-@@ -952,6 +952,9 @@ static int mcp251x_open(struct net_devic
+@@ -951,6 +951,9 @@ static int mcp251x_open(struct net_devic
priv->tx_skb = NULL;
priv->tx_len = 0;
diff --git a/target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch b/target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch
index 6442338a6c..8875a8ac37 100644
--- a/target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0315-usb-gadget-ethernet-Re-enable-Jumbo-frames.patch
@@ -18,7 +18,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
--- a/drivers/usb/gadget/function/u_ether.c
+++ b/drivers/usb/gadget/function/u_ether.c
-@@ -848,6 +848,10 @@ struct net_device *gether_setup_name_def
+@@ -850,6 +850,10 @@ struct net_device *gether_setup_name_def
net->ethtool_ops = &ops;
SET_NETDEV_DEVTYPE(net, &gadget_type);
diff --git a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
index b60e9d3230..a61a4ec17f 100644
--- a/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
+++ b/target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
--- a/drivers/usb/serial/option.c
+++ b/drivers/usb/serial/option.c
-@@ -1947,7 +1947,8 @@ static const struct usb_device_id option
+@@ -1948,7 +1948,8 @@ static const struct usb_device_id option
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) }, /* D-Link DWM-156 (variant) */
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
{ USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
diff --git a/target/linux/generic/backport-4.14/049-v4.20-mips-remove-superfluous-check-for-linux.patch b/target/linux/generic/backport-4.14/049-v4.20-mips-remove-superfluous-check-for-linux.patch
deleted file mode 100644
index 4e9279a9ec..0000000000
--- a/target/linux/generic/backport-4.14/049-v4.20-mips-remove-superfluous-check-for-linux.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 1287533d3d95d5ad8b02773733044500b1be06bc Mon Sep 17 00:00:00 2001
-From: Sean Young <sean@mess.org>
-Date: Fri, 16 Nov 2018 16:09:39 +0000
-Subject: MIPS: Remove superfluous check for __linux__
-
-When building BPF code using "clang -target bpf -c", clang does not
-define __linux__.
-
-To build BPF IR decoders the include linux/lirc.h is needed which
-includes linux/types.h. Currently this workaround is needed:
-
-https://git.linuxtv.org/v4l-utils.git/commit/?id=dd3ff81f58c4e1e6f33765dc61ad33c48ae6bb07
-
-This check might otherwise be useful to stop users from using a non-linux
-compiler, but if you're doing that you are going to have a lot more
-trouble anyway.
-
-Signed-off-by: Sean Young <sean@mess.org>
-Signed-off-by: Paul Burton <paul.burton@mips.com>
-Patchwork: https://patchwork.linux-mips.org/patch/21149/
-Cc: Ralf Baechle <ralf@linux-mips.org>
-Cc: James Hogan <jhogan@kernel.org>
-Cc: linux-mips@linux-mips.org
-Cc: linux-kernel@vger.kernel.org
----
- arch/mips/include/uapi/asm/sgidefs.h | 8 --------
- 1 file changed, 8 deletions(-)
-
-(limited to 'arch/mips/include/uapi/asm/sgidefs.h')
-
---- a/arch/mips/include/uapi/asm/sgidefs.h
-+++ b/arch/mips/include/uapi/asm/sgidefs.h
-@@ -12,14 +12,6 @@
- #define __ASM_SGIDEFS_H
-
- /*
-- * Using a Linux compiler for building Linux seems logic but not to
-- * everybody.
-- */
--#ifndef __linux__
--#error Use a Linux compiler or give up.
--#endif
--
--/*
- * Definitions for the ISA levels
- *
- * With the introduction of MIPS32 / MIPS64 instruction sets definitions