aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-01-20 20:36:19 +0100
committerPetr Štetiar <ynezz@true.cz>2020-01-24 08:25:39 +0100
commit4e91c4e1563a6fa2885b316fcce6a27a49c36743 (patch)
tree3471e20a1b4f840d2b30828e62965e6dc276d65c
parent4a58a871c46a589263f565ee7b755d5f3d695580 (diff)
downloadupstream-4e91c4e1563a6fa2885b316fcce6a27a49c36743.tar.gz
upstream-4e91c4e1563a6fa2885b316fcce6a27a49c36743.tar.bz2
upstream-4e91c4e1563a6fa2885b316fcce6a27a49c36743.zip
ramips: mt7621: ubnt-erx: allow sysupgrade from master
Currently it's not possible to downgrade from master: Device ubiquiti,edgerouterx not supported by this image Supported devices: ubnt-erx So fix it by adding a DTS based device name from master into SUPPORTED_DEVICES list. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8efda0784c..9c16705e2f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -488,6 +488,7 @@ define Device/ubnt-erx
KERNEL_INITRAMFS := $$(KERNEL) | ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_TITLE := Ubiquiti EdgeRouter X
+ SUPPORTED_DEVICES += ubiquiti,edgerouterx
endef
TARGET_DEVICES += ubnt-erx
@@ -496,6 +497,7 @@ define Device/ubnt-erx-sfp
DTS := UBNT-ERX-SFP
DEVICE_TITLE := Ubiquiti EdgeRouter X-SFP
DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x kmod-i2c-gpio-custom
+ SUPPORTED_DEVICES += ubiquiti,edgerouterx-sfp
endef
TARGET_DEVICES += ubnt-erx-sfp