aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-15 21:37:31 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-15 21:37:31 +0000
commit41027beb691a6a2502d1cdf9707d800ca0bbcb43 (patch)
tree0a269cc8fff10a61a1d1a283bb0e3f3d86e694df
parent9a97c56535bb797f63847b8268efb0b035dddb51 (diff)
downloadupstream-41027beb691a6a2502d1cdf9707d800ca0bbcb43.tar.gz
upstream-41027beb691a6a2502d1cdf9707d800ca0bbcb43.tar.bz2
upstream-41027beb691a6a2502d1cdf9707d800ca0bbcb43.zip
ubifs: remove breaking commas from ubi calls
The extra commas get output by the shell resulting in errors since the commands that get called with those extra commas are then malformed. Signed-off-by: Joris de Vries <joris@apptrician.nl> SVN-Revision: 38419
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index c79d823538..8f895a3435 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -125,7 +125,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/mkfs.ubifs \
$(if $($(PROFILE)_UBIFS_OPTS), \
$(shell echo $($(PROFILE)_UBIFS_OPTS)), \
- $(shell echo $(UBIFS_OPTS)), \
+ $(shell echo $(UBIFS_OPTS)) \
) \
$(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(STAGING_DIR_HOST)/bin/ubinize \
$(if $($(PROFILE)_UBI_OPTS), \
$(shell echo $($(PROFILE)_UBI_OPTS)), \
- $(shell echo $(UBI_OPTS)), \
+ $(shell echo $(UBI_OPTS)) \
) \
-o $(KDIR)/root.ubi \
ubinize.cfg \