aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Antony <antony@phenome.org>2017-12-28 18:21:15 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-02-17 01:15:24 +0100
commit3c24a1d423a6052b101c00cb7d94e70d72702639 (patch)
tree663f8e2203e3352bbacb72c6ddf8aba19338799b
parentb7a1aa4df2a9834bb7339712670abbe1a05dc01c (diff)
downloadupstream-3c24a1d423a6052b101c00cb7d94e70d72702639.tar.gz
upstream-3c24a1d423a6052b101c00cb7d94e70d72702639.tar.bz2
upstream-3c24a1d423a6052b101c00cb7d94e70d72702639.zip
sunxi: add support for NanoPi NEO Plus2 board
arm64: allwinner: h5: NanoPi NEO Plus2 DT support Add initial DT for NanoPi NEO Plus2 by FriendlyARM - Allwinner quad core H5 Cortex A53 with an ARM Mali-450MP GPU - 1 GB DDR3 RAM - 8GB eMMC flash (Samsung KLM8G1WEPD-B031) - micro SD card slot - Gigabit Ethernet (external RTL8211E-VB-CG chip) - 802.11 b/g/n WiFi, Bluetooth 4.0 (Ampak AP6212A module) - 2x USB 2.0 host ports & 2x USB via headers Signed-off-by: Antony Antony <antony@phenome.org>
-rw-r--r--package/boot/uboot-sunxi/Makefile9
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
2 files changed, 19 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 056300e189..321e7e9c03 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -168,6 +168,14 @@ define U-Boot/pangolin
UENV:=pangolin
endef
+define U-Boot/nanopi_neo_plus2
+ BUILD_SUBTARGET:=cortexa53
+ NAME:=NanoPi NEO Plus2 (H5)
+ BUILD_DEVICES:=sun50i-h5-nanopi-neo-plus2
+ DEPENDS:=+PACKAGE_u-boot-nanopi_neo_plus2:arm-trusted-firmware-sunxi
+ UENV:=a64
+endef
+
define U-Boot/pine64_plus
BUILD_SUBTARGET:=cortexa53
NAME:=Pine64 Plus A64
@@ -197,6 +205,7 @@ UBOOT_TARGETS := \
Lamobo_R1 \
nanopi_m1_plus \
nanopi_neo \
+ nanopi_neo_plus2 \
orangepi_r1 \
orangepi_plus \
orangepi_2 \
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index bbb253f0ae..eb31aa8d4c 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -7,6 +7,16 @@
#
ifeq ($(SUBTARGET),cortexa53)
+define Device/sun50i-h5-nanopi-neo-plus2
+ DEVICE_TITLE:=Nanopi NEO Plus2 (H5)
+ SUPPORTED_DEVICES:=nanopi-neo-plus2
+ SUNXI_DTS:=allwinner/sun50i-h5-nanopi-neo-plus2
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-nanopi-neo-plus2
+
define Device/sun50i-a64-pine64-plus
DEVICE_TITLE:=Pine64 Plus A64
SUPPORTED_DEVICES:=pine64,pine64-plus