aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-08-23 15:50:50 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-29 11:31:20 +0200
commit39ae849d0d23409ba6557df9055b306cf29df475 (patch)
treef941ccaa93f1f13df0bbaee8cc0fcee54c24a8f1
parent4e93d17f2a8d701349c1dabaab38c869a968e93c (diff)
downloadupstream-39ae849d0d23409ba6557df9055b306cf29df475.tar.gz
upstream-39ae849d0d23409ba6557df9055b306cf29df475.tar.bz2
upstream-39ae849d0d23409ba6557df9055b306cf29df475.zip
ath79: image: add supported string for routerstations and ja76pf2
Now that the md5 check is fixed and metadata present, sysupgrade on ar71xx will complain about device not being supported by the image. Since the cause is not matching strings for supported devices add them accordingly. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl> (cherry picked from commit a45cf75eca4069f24bf5bba8f245de2e553f7f78)
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
-rw-r--r--target/linux/ath79/image/generic.mk1
2 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index f9f74d0f51..ac3b935900 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -218,6 +218,7 @@ define Device/ubnt_routerstation
UBNT_TYPE := RSx
UBNT_CHIP := ar7100
DEVICE_PACKAGES += -swconfig
+ SUPPORTED_DEVICES += routerstation
endef
TARGET_DEVICES += ubnt_routerstation
@@ -227,6 +228,7 @@ define Device/ubnt_routerstation-pro
UBNT_BOARD := RSPRO
UBNT_TYPE := RSPRO
UBNT_CHIP := ar7100pro
+ SUPPORTED_DEVICES += routerstation-pro
endef
TARGET_DEVICES += ubnt_routerstation-pro
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a2b82cbf7f..3b7fdb7015 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -479,6 +479,7 @@ define Device/jjplus_ja76pf2
KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
KERNEL_INITRAMFS := kernel-bin | append-dtb
IMAGE_SIZE := 16000k
+ SUPPORTED_DEVICES += ja76pf2
endef
TARGET_DEVICES += jjplus_ja76pf2