aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
commit383a21f3c591a8ba46ae8336ff5266d7a02fd281 (patch)
treec87e967bb5d3832a3a2ac41b89e01f1536b78644
parent54a1fcd9c16ab3996ec30d2110d45bfca4c6e72d (diff)
downloadupstream-383a21f3c591a8ba46ae8336ff5266d7a02fd281.tar.gz
upstream-383a21f3c591a8ba46ae8336ff5266d7a02fd281.tar.bz2
upstream-383a21f3c591a8ba46ae8336ff5266d7a02fd281.zip
use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
SVN-Revision: 7043
-rw-r--r--package/base-files/Makefile5
-rw-r--r--target/linux/generic-2.4/base-files/etc/sysctl.conf (renamed from package/base-files/files/etc/sysctl.conf)0
-rw-r--r--target/linux/generic-2.6/base-files/etc/sysctl.conf10
3 files changed, 14 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1e1610c5d7..e267b7f78b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -13,7 +13,7 @@ PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-PKG_FILE_DEPEND:=$(PLATFORM_DIR)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR) $(GENERIC_PLATFORM_DIR)/base-files
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
@@ -110,6 +110,9 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
+ if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
fi
diff --git a/package/base-files/files/etc/sysctl.conf b/target/linux/generic-2.4/base-files/etc/sysctl.conf
index e60038cf35..e60038cf35 100644
--- a/package/base-files/files/etc/sysctl.conf
+++ b/target/linux/generic-2.4/base-files/etc/sysctl.conf
diff --git a/target/linux/generic-2.6/base-files/etc/sysctl.conf b/target/linux/generic-2.6/base-files/etc/sysctl.conf
new file mode 100644
index 0000000000..a05498cd6c
--- /dev/null
+++ b/target/linux/generic-2.6/base-files/etc/sysctl.conf
@@ -0,0 +1,10 @@
+kernel.panic=3
+net.ipv4.conf.default.arp_ignore=1
+net.ipv4.conf.all.arp_ignore=1
+net.ipv4.ip_forward=1
+net.ipv4.icmp_echo_ignore_broadcasts=1
+net.ipv4.icmp_ignore_bogus_error_responses=1
+net.ipv4.tcp_fin_timeout=30
+net.ipv4.tcp_keepalive_time=120
+net.ipv4.tcp_syncookies=1
+net.ipv4.tcp_timestamps=0