aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-05 09:56:52 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-05 10:00:01 +0200
commit36c6ba3735f06f435af66175ace0dd192601ac85 (patch)
tree88b1c281dc7d6874d352b6a85bab1a2971b64401
parentb9f926e15146bcb3688d66562fd0f1a3e79ca747 (diff)
downloadupstream-36c6ba3735f06f435af66175ace0dd192601ac85.tar.gz
upstream-36c6ba3735f06f435af66175ace0dd192601ac85.tar.bz2
upstream-36c6ba3735f06f435af66175ace0dd192601ac85.zip
imx6: use BUILD_DEVICES in uboot-imx6 for mx6cuboxi
Fixes build with the default profile Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/boot/uboot-imx6/Makefile2
-rw-r--r--target/linux/imx6/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 6973cda5ae..3eba249bf3 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -24,6 +24,8 @@ define U-Boot/mx6cuboxi
NAME:=SolidRun Cubox-i boards
UBOOT_IMAGE:=SPL u-boot.img
UBOOT_MAKE_FLAGS:=SPL u-boot.img
+ BUILD_DEVICES:=cubox-i
+ HIDDEN:=1
endef
define U-Boot/mx6sabresd
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index b6885eff60..f13412f1e3 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -168,7 +168,7 @@ define Device/cubox-i
BOOT_SCRIPT = bootscript-cubox
DEVICE_NAME := cubox
DEVICE_TITLE := SolidRun CuBox-i
- DEVICE_PACKAGES := u-boot-mx6cuboxi kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
+ DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
DEVICE_DTS := imx6q-cubox-i imx6dl-cubox-i imx6q-hummingboard imx6dl-hummingboard
IMAGES := combined.bin
FILESYSTEMS := squashfs