aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-02-26 16:40:21 +0100
committerJo-Philipp Wich <jo@mein.io>2020-02-26 16:40:25 +0100
commit0e9e5b15538e530a88572bc58c689afeba91c0fe (patch)
tree30a893d5daa69d2ac3587e8dd3012f816b2587a0
parent9e2a1af62f9ad68c16c2c58a73b4ae998b674b18 (diff)
downloadupstream-0e9e5b15538e530a88572bc58c689afeba91c0fe.tar.gz
upstream-0e9e5b15538e530a88572bc58c689afeba91c0fe.tar.bz2
upstream-0e9e5b15538e530a88572bc58c689afeba91c0fe.zip
Revert "ppp: backport security fixes"
This reverts commit 6b7eeb74dbf8b491b6426820bfa230fca60047dc since it didn't contain a reference to the CVE it addresses. The next commit will re-add the commit including a CVE reference in its commit message. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/network/services/ppp/Makefile2
-rw-r--r--package/network/services/ppp/patches/700-radius-Prevent-buffer-overflow-in-rc_mksid.patch30
-rw-r--r--package/network/services/ppp/patches/701-pppd-Fix-bounds-check-in-EAP-code.patch37
-rw-r--r--package/network/services/ppp/patches/702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP.patch61
4 files changed, 1 insertions, 129 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index d21d1e0438..10e7656ea4 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
-PKG_RELEASE:=3
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/paulusmack/ppp
diff --git a/package/network/services/ppp/patches/700-radius-Prevent-buffer-overflow-in-rc_mksid.patch b/package/network/services/ppp/patches/700-radius-Prevent-buffer-overflow-in-rc_mksid.patch
deleted file mode 100644
index 1c5722e6dd..0000000000
--- a/package/network/services/ppp/patches/700-radius-Prevent-buffer-overflow-in-rc_mksid.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 858976b1fc3107f1261aae337831959b511b83c2 Mon Sep 17 00:00:00 2001
-From: Paul Mackerras <paulus@ozlabs.org>
-Date: Sat, 4 Jan 2020 12:01:32 +1100
-Subject: [PATCH] radius: Prevent buffer overflow in rc_mksid()
-
-On some systems getpid() can return a value greater than 65535.
-Increase the size of buf[] to allow for this, and use slprintf()
-to make sure we never overflow it.
-
-Signed-off-by: Paul Mackerras <paulus@ozlabs.org>
----
- pppd/plugins/radius/util.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pppd/plugins/radius/util.c b/pppd/plugins/radius/util.c
-index 6f976a712951..740131e8377c 100644
---- a/pppd/plugins/radius/util.c
-+++ b/pppd/plugins/radius/util.c
-@@ -73,9 +73,9 @@ void rc_mdelay(int msecs)
- char *
- rc_mksid (void)
- {
-- static char buf[15];
-+ static char buf[32];
- static unsigned short int cnt = 0;
-- sprintf (buf, "%08lX%04X%02hX",
-+ slprintf(buf, sizeof(buf), "%08lX%04X%02hX",
- (unsigned long int) time (NULL),
- (unsigned int) getpid (),
- cnt & 0xFF);
diff --git a/package/network/services/ppp/patches/701-pppd-Fix-bounds-check-in-EAP-code.patch b/package/network/services/ppp/patches/701-pppd-Fix-bounds-check-in-EAP-code.patch
deleted file mode 100644
index c2ca9729ec..0000000000
--- a/package/network/services/ppp/patches/701-pppd-Fix-bounds-check-in-EAP-code.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 8d7970b8f3db727fe798b65f3377fe6787575426 Mon Sep 17 00:00:00 2001
-From: Paul Mackerras <paulus@ozlabs.org>
-Date: Mon, 3 Feb 2020 15:53:28 +1100
-Subject: [PATCH] pppd: Fix bounds check in EAP code
-
-Given that we have just checked vallen < len, it can never be the case
-that vallen >= len + sizeof(rhostname). This fixes the check so we
-actually avoid overflowing the rhostname array.
-
-Reported-by: Ilja Van Sprundel <ivansprundel@ioactive.com>
-Signed-off-by: Paul Mackerras <paulus@ozlabs.org>
----
- pppd/eap.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/pppd/eap.c b/pppd/eap.c
-index 94407f56a336..1b93db01aebd 100644
---- a/pppd/eap.c
-+++ b/pppd/eap.c
-@@ -1420,7 +1420,7 @@ int len;
- }
-
- /* Not so likely to happen. */
-- if (vallen >= len + sizeof (rhostname)) {
-+ if (len - vallen >= sizeof (rhostname)) {
- dbglog("EAP: trimming really long peer name down");
- BCOPY(inp + vallen, rhostname, sizeof (rhostname) - 1);
- rhostname[sizeof (rhostname) - 1] = '\0';
-@@ -1846,7 +1846,7 @@ int len;
- }
-
- /* Not so likely to happen. */
-- if (vallen >= len + sizeof (rhostname)) {
-+ if (len - vallen >= sizeof (rhostname)) {
- dbglog("EAP: trimming really long peer name down");
- BCOPY(inp + vallen, rhostname, sizeof (rhostname) - 1);
- rhostname[sizeof (rhostname) - 1] = '\0';
diff --git a/package/network/services/ppp/patches/702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP.patch b/package/network/services/ppp/patches/702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP.patch
deleted file mode 100644
index 7286d81a56..0000000000
--- a/package/network/services/ppp/patches/702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 8d45443bb5c9372b4c6a362ba2f443d41c5636af Mon Sep 17 00:00:00 2001
-From: Paul Mackerras <paulus@ozlabs.org>
-Date: Mon, 3 Feb 2020 16:31:42 +1100
-Subject: [PATCH] pppd: Ignore received EAP messages when not doing EAP
-
-This adds some basic checks to the subroutines of eap_input to check
-that we have requested or agreed to doing EAP authentication before
-doing any processing on the received packet. The motivation is to
-make it harder for a malicious peer to disrupt the operation of pppd
-by sending unsolicited EAP packets. Note that eap_success() already
-has a check that the EAP client state is reasonable, and does nothing
-(apart from possibly printing a debug message) if not.
-
-Signed-off-by: Paul Mackerras <paulus@ozlabs.org>
----
- pppd/eap.c | 18 ++++++++++++++++++
- 1 file changed, 18 insertions(+)
-
-diff --git a/pppd/eap.c b/pppd/eap.c
-index 1b93db01aebd..082e95343120 100644
---- a/pppd/eap.c
-+++ b/pppd/eap.c
-@@ -1328,6 +1328,12 @@ int len;
- int fd;
- #endif /* USE_SRP */
-
-+ /*
-+ * Ignore requests if we're not open
-+ */
-+ if (esp->es_client.ea_state <= eapClosed)
-+ return;
-+
- /*
- * Note: we update es_client.ea_id *only if* a Response
- * message is being generated. Otherwise, we leave it the
-@@ -1736,6 +1742,12 @@ int len;
- u_char dig[SHA_DIGESTSIZE];
- #endif /* USE_SRP */
-
-+ /*
-+ * Ignore responses if we're not open
-+ */
-+ if (esp->es_server.ea_state <= eapClosed)
-+ return;
-+
- if (esp->es_server.ea_id != id) {
- dbglog("EAP: discarding Response %d; expected ID %d", id,
- esp->es_server.ea_id);
-@@ -2047,6 +2059,12 @@ u_char *inp;
- int id;
- int len;
- {
-+ /*
-+ * Ignore failure messages if we're not open
-+ */
-+ if (esp->es_client.ea_state <= eapClosed)
-+ return;
-+
- if (!eap_client_active(esp)) {
- dbglog("EAP unexpected failure message in state %s (%d)",
- eap_state_name(esp->es_client.ea_state),