aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-24 18:53:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-24 18:53:14 +0000
commitf76a752c5768ba7e58fcacf43bef0afd756b81af (patch)
treea3d35129946daa60d66cf6718eaa0e17a2226611
parent11e93be20d363630dcaca8d2bb7febe2c82ecb06 (diff)
downloadupstream-f76a752c5768ba7e58fcacf43bef0afd756b81af.tar.gz
upstream-f76a752c5768ba7e58fcacf43bef0afd756b81af.tar.bz2
upstream-f76a752c5768ba7e58fcacf43bef0afd756b81af.zip
generic/4.0: refresh patches
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44532
-rw-r--r--target/linux/generic/patches-4.0/305-mips_module_reloc.patch2
-rw-r--r--target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch8
-rw-r--r--target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch4
-rw-r--r--target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch4
-rw-r--r--target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch4
-rw-r--r--target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch2
-rw-r--r--target/linux/generic/patches-4.0/862-gpio_spi_driver.patch4
7 files changed, 14 insertions, 14 deletions
diff --git a/target/linux/generic/patches-4.0/305-mips_module_reloc.patch b/target/linux/generic/patches-4.0/305-mips_module_reloc.patch
index 2e92916f97..752d597412 100644
--- a/target/linux/generic/patches-4.0/305-mips_module_reloc.patch
+++ b/target/linux/generic/patches-4.0/305-mips_module_reloc.patch
@@ -150,7 +150,7 @@
{
+#ifdef MODULE_START
return __vmalloc_node_range(size, 1, MODULE_START, MODULE_END,
- GFP_KERNEL, PAGE_KERNEL, NUMA_NO_NODE,
+ GFP_KERNEL, PAGE_KERNEL, 0, NUMA_NO_NODE,
__builtin_return_address(0));
+#else
+ void *ptr;
diff --git a/target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch b/target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
index c0ee1f7673..07562b28fc 100644
--- a/target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
+++ b/target/linux/generic/patches-4.0/491-ubi-auto-create-ubiblock-device-for-rootfs.patch
@@ -11,8 +11,8 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
--- a/drivers/mtd/ubi/block.c
+++ b/drivers/mtd/ubi/block.c
-@@ -614,6 +614,44 @@ static int __init ubiblock_create_from_p
- return ret;
+@@ -614,6 +614,44 @@ static void __init ubiblock_create_from_
+ }
}
+#define UBIFS_NODE_MAGIC 0x06101831
@@ -57,8 +57,8 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
{
struct ubiblock *next;
@@ -644,6 +682,10 @@ int __init ubiblock_init(void)
- if (ret)
- goto err_remove;
+ */
+ ubiblock_create_from_param();
+ /* auto-attach "rootfs" volume if existing and non-ubifs */
+ if (config_enabled(CONFIG_MTD_ROOTFS_ROOT_DEV))
diff --git a/target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch b/target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch
index bd7a7ffdef..6d58189786 100644
--- a/target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch
+++ b/target/linux/generic/patches-4.0/604-netfilter_conntrack_flush.patch
@@ -8,7 +8,7 @@
#include <net/net_namespace.h>
#ifdef CONFIG_SYSCTL
#include <linux/sysctl.h>
-@@ -259,10 +260,66 @@ static int ct_open(struct inode *inode,
+@@ -265,10 +266,66 @@ static int ct_open(struct inode *inode,
sizeof(struct ct_iter_state));
}
@@ -75,7 +75,7 @@
.llseek = seq_lseek,
.release = seq_release_net,
};
-@@ -364,7 +421,7 @@ static int nf_conntrack_standalone_init_
+@@ -370,7 +427,7 @@ static int nf_conntrack_standalone_init_
{
struct proc_dir_entry *pde;
diff --git a/target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch b/target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch
index 5d67818724..6cf6568ab5 100644
--- a/target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch
+++ b/target/linux/generic/patches-4.0/617-netfilter_skip_filter_sysctl.patch
@@ -63,7 +63,7 @@
net->ipv6.ip6table_filter);
--- a/net/netfilter/nf_conntrack_standalone.c
+++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -501,6 +501,13 @@ static struct ctl_table nf_ct_sysctl_tab
+@@ -507,6 +507,13 @@ static struct ctl_table nf_ct_sysctl_tab
.extra2 = &log_invalid_proto_max,
},
{
@@ -77,7 +77,7 @@
.procname = "nf_conntrack_expect_max",
.data = &nf_ct_expect_max,
.maxlen = sizeof(int),
-@@ -536,6 +543,7 @@ static int nf_conntrack_standalone_init_
+@@ -542,6 +549,7 @@ static int nf_conntrack_standalone_init_
table[2].data = &net->ct.htable_size;
table[3].data = &net->ct.sysctl_checksum;
table[4].data = &net->ct.sysctl_log_invalid;
diff --git a/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
index fb5c389ea1..f09875c02c 100644
--- a/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-4.0/645-bridge_multicast_to_unicast.patch
@@ -273,7 +273,7 @@
};
struct net_bridge_mdb_entry
-@@ -476,7 +479,8 @@ void br_multicast_free_pg(struct rcu_hea
+@@ -480,7 +483,8 @@ void br_multicast_free_pg(struct rcu_hea
struct net_bridge_port_group *
br_multicast_new_port_group(struct net_bridge_port *port, struct br_ip *group,
struct net_bridge_port_group __rcu *next,
@@ -285,7 +285,7 @@
void br_mdb_notify(struct net_device *dev, struct net_bridge_port *port,
--- a/net/bridge/br_mdb.c
+++ b/net/bridge/br_mdb.c
-@@ -342,7 +342,7 @@ static int br_mdb_add_group(struct net_b
+@@ -343,7 +343,7 @@ static int br_mdb_add_group(struct net_b
break;
}
diff --git a/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch b/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
index 230c8083c7..cf5737ddb1 100644
--- a/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
+++ b/target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
@@ -472,7 +472,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
return 0;
nla_put_failure:
-@@ -1769,6 +2022,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1777,6 +2030,7 @@ static const struct nla_policy ip6_tnl_p
[IFLA_IPTUN_FLOWINFO] = { .type = NLA_U32 },
[IFLA_IPTUN_FLAGS] = { .type = NLA_U32 },
[IFLA_IPTUN_PROTO] = { .type = NLA_U8 },
diff --git a/target/linux/generic/patches-4.0/862-gpio_spi_driver.patch b/target/linux/generic/patches-4.0/862-gpio_spi_driver.patch
index 8ffea82ee3..be059383f3 100644
--- a/target/linux/generic/patches-4.0/862-gpio_spi_driver.patch
+++ b/target/linux/generic/patches-4.0/862-gpio_spi_driver.patch
@@ -345,7 +345,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
+MODULE_LICENSE("GPL v2");
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -232,6 +232,15 @@ config SPI_IMG_SPFI
+@@ -242,6 +242,15 @@ config SPI_IMG_SPFI
This enables support for the SPFI master controller found on
IMG SoCs.
@@ -363,7 +363,7 @@ Please use the new mainline SPI-GPIO driver, as of 2.6.29.
depends on ARCH_MXC || COMPILE_TEST
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_FSL_LIB) += spi-fsl-li
+@@ -41,6 +41,7 @@ obj-$(CONFIG_SPI_FSL_LIB) += spi-fsl-li
obj-$(CONFIG_SPI_FSL_ESPI) += spi-fsl-espi.o
obj-$(CONFIG_SPI_FSL_SPI) += spi-fsl-spi.o
obj-$(CONFIG_SPI_GPIO) += spi-gpio.o