aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-16 08:00:17 +0000
committerJohn Crispin <john@openwrt.org>2015-02-16 08:00:17 +0000
commitdd41c1927cd850b5c40e6f33a7137b262911cc99 (patch)
tree4374e4592e523c1e9ab502bbbf87c13ca33b15d7
parent4e5c2b6f46a2a5fd26c37e0a1c0f8d940688a6f3 (diff)
downloadupstream-dd41c1927cd850b5c40e6f33a7137b262911cc99.tar.gz
upstream-dd41c1927cd850b5c40e6f33a7137b262911cc99.tar.bz2
upstream-dd41c1927cd850b5c40e6f33a7137b262911cc99.zip
linux: fix kmod-usb-net-* for >= 3.17
Kernel commit 1bb5a356c3ea ("net: reduce USB network driver config options.") hid the USB network drivers behind the new config symbol CONFIG_USB_NET_DRIVERS. Signed-off-by: Bjørn Mork <bjorn@mork.no> SVN-Revision: 44460
-rw-r--r--package/kernel/linux/modules/usb.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 431c7baa2c..6faa437bca 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -992,7 +992,8 @@ $(eval $(call KernelPackage,usb-atm-cxacru))
define KernelPackage/usb-net
TITLE:=Kernel modules for USB-to-Ethernet convertors
DEPENDS:=+kmod-mii
- KCONFIG:=CONFIG_USB_USBNET
+ KCONFIG:=CONFIG_USB_USBNET \
+ CONFIG_USB_NET_DRIVERS@ge3.18
AUTOLOAD:=$(call AutoProbe,usbnet)
FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/usbnet.ko
$(call AddDepends/usb)