aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-06-23 23:20:53 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commitc55fadcacb8d47f08465e0e75c96fa5ddf649e16 (patch)
tree2addbf03e69221a963ec03f42df6555bce9a9116
parent5b7f59225118a3553af5e9d485e2445f28444fb9 (diff)
downloadupstream-c55fadcacb8d47f08465e0e75c96fa5ddf649e16.tar.gz
upstream-c55fadcacb8d47f08465e0e75c96fa5ddf649e16.tar.bz2
upstream-c55fadcacb8d47f08465e0e75c96fa5ddf649e16.zip
ramips: image: simplify TP-Link Archer devices definitions
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
-rw-r--r--target/linux/ramips/image/mt7620.mk21
1 files changed, 10 insertions, 11 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index fd9f10a246..d435e9f587 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -25,39 +25,38 @@ define Device/ai-br100
endef
TARGET_DEVICES += ai-br100
-define Device/ArcherC20i
- DTS := ArcherC20i
- SUPPORTED_DEVICES := c20i
- TPLINK_BOARD_ID := ArcherC20i
+define Device/Archer
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header
IMAGE/factory.bin := tplink-v2-image
IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata
+endef
+
+define Device/ArcherC20i
+ $(Device/Archer)
+ DTS := ArcherC20i
+ SUPPORTED_DEVICES := c20i
+ TPLINK_BOARD_ID := ArcherC20i
IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
define Device/ArcherC50
+ $(Device/Archer)
DTS := ArcherC50
SUPPORTED_DEVICES := c50
TPLINK_BOARD_ID := ArcherC50
- KERNEL := $(KERNEL_DTB)
- KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header
- IMAGE/factory.bin := tplink-v2-image
- IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata
IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC50
endef
TARGET_DEVICES += ArcherC50
define Device/ArcherMR200
+ $(Device/Archer)
DTS := ArcherMR200
SUPPORTED_DEVICES := mr200
TPLINK_BOARD_ID := ArcherMR200
- KERNEL := $(KERNEL_DTB)
- KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header
- IMAGE/sysupgrade.bin := tplink-v2-image -s | append-metadata
DEVICE_PACKAGES := kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb-enablemodem
DEVICE_TITLE := TP-Link ArcherMR200
endef