aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-10-30 22:35:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-10-30 22:35:59 +0000
commitb013e4eec460680b442dc027f46fcb9ac106d917 (patch)
tree1f09d86ef1aafa1e1e1da35a921f8e0c973601c2
parent3403d66f43299c952b7008b45544ce55a8fac933 (diff)
downloadupstream-b013e4eec460680b442dc027f46fcb9ac106d917.tar.gz
upstream-b013e4eec460680b442dc027f46fcb9ac106d917.tar.bz2
upstream-b013e4eec460680b442dc027f46fcb9ac106d917.zip
add kmod-leds-net5501
Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> SVN-Revision: 23729
-rw-r--r--package/kernel/modules/other.mk15
-rw-r--r--target/linux/x86/net5501/target.mk2
2 files changed, 16 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 623f5078e8..b9797547ea 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -444,6 +444,21 @@ endef
$(eval $(call KernelPackage,leds-net48xx))
+define KernelPackage/leds-net5501
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Soekris Net5501 LED support
+ DEPENDS:=@TARGET_x86 +kmod-gpio-cs5535 +kmod-leds-gpio
+ KCONFIG:=CONFIG_LEDS_NET5501
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-net5501.ko
+ AUTOLOAD:=$(call AutoLoad,50,leds-net5501)
+endef
+
+define KernelPackage/leds-net5501/description
+ Kernel module for Soekris Net5501 LEDs
+endef
+
+$(eval $(call KernelPackage,leds-net5501))
+
define KernelPackage/leds-rb750
SUBMENU:=$(OTHER_MENU)
diff --git a/target/linux/x86/net5501/target.mk b/target/linux/x86/net5501/target.mk
index c583966a40..ebd6c4a9c6 100644
--- a/target/linux/x86/net5501/target.mk
+++ b/target/linux/x86/net5501/target.mk
@@ -2,7 +2,7 @@ BOARDNAME:=Soekris net5501
DEFAULT_PACKAGES += kmod-ata-via-sata kmod-crypto-hw-geode \
kmod-gpio-cs5535 kmod-gpio-nsc kmod-gpio-pc8736x \
kmod-wdt-geode kmod-hwmon-core kmod-hwmon-pc87360 \
- kmod-via-rhine \
+ kmod-via-rhine kmod-leds-net5501 \
kmod-i2c-core kmod-i2c-gpio \
kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci