aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-29 12:20:39 +0000
committerJohn Crispin <john@openwrt.org>2015-05-29 12:20:39 +0000
commit590be1fd872e39b54a3bd23949e76b7af375b68b (patch)
treefb67b50609a37f07ec481f4b3f9a07c005411381
parent0d7666fd73d774b8b2b69ea52d0a86a774c66b83 (diff)
downloadupstream-590be1fd872e39b54a3bd23949e76b7af375b68b.tar.gz
upstream-590be1fd872e39b54a3bd23949e76b7af375b68b.tar.bz2
upstream-590be1fd872e39b54a3bd23949e76b7af375b68b.zip
ixp4xx: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45826
-rw-r--r--package/boot/apex/Makefile5
-rw-r--r--target/linux/ixp4xx/image/Makefile4
2 files changed, 7 insertions, 2 deletions
diff --git a/package/boot/apex/Makefile b/package/boot/apex/Makefile
index 1a1ab1b28b..f154f9606e 100644
--- a/package/boot/apex/Makefile
+++ b/package/boot/apex/Makefile
@@ -6,6 +6,7 @@
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=apex
PKG_VERSION:=1.6.9
@@ -54,4 +55,8 @@ define Package/apex/install
$(CP) $(PKG_BUILD_DIR)/out/*.bin $(1)/
endef
+define Build/InstallDev
+ $(CP) $(PKG_BUILD_DIR)/out/*.bin $(KERNEL_BUILD_DIR)
+endef
+
$(eval $(call BuildPackage,apex))
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 7488d757b6..bbd62f0513 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/image.mk
ifdef CONFIG_PACKAGE_apex
define Image/Build/Linksys
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -L $(BIN_DIR)/apex/apex-$(2)-armeb.bin \
+ -L $(KDIR)/apex-$(2)-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).bin
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
- -F -L $(BIN_DIR)/apex/apex-$(2)-16mb-armeb.bin \
+ -F -L $(KDIR)/apex-$(2)-16mb-armeb.bin \
-k $(BIN_DIR)/$(IMG_PREFIX)-$(2)-zImage \
-r rootfs:$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
-p -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-16mb.bin