aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Segers <foss@volatilesystems.org>2019-04-06 23:16:31 +0200
committerHans Dedecker <dedeckeh@gmail.com>2019-04-07 19:39:26 +0200
commit4b4de23dfb431ccb7d49f3c0efb06e3cb9787b0e (patch)
treeb8403496794721f926d81c43f615c031ae80b305
parentca8b4d684b57d7eee0329eae86d68ec5581615f7 (diff)
downloadupstream-4b4de23dfb431ccb7d49f3c0efb06e3cb9787b0e.tar.gz
upstream-4b4de23dfb431ccb7d49f3c0efb06e3cb9787b0e.tar.bz2
upstream-4b4de23dfb431ccb7d49f3c0efb06e3cb9787b0e.zip
openssl: update to 1.0.2r
This bump contains bug and security fixes. Compile-tested on ar71xx, ramips/mt7621 and x86/64. Run-tested on ramips/mt7621. Signed-off-by: Stijn Segers <foss@volatilesystems.org> Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_HASH fixup]
-rw-r--r--package/libs/openssl/Makefile4
-rw-r--r--package/libs/openssl/patches/200-parallel_build.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index a4781e9eee..2902ce15c7 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_BASE:=1.0.2
-PKG_BUGFIX:=q
+PKG_BUGFIX:=r
PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
PKG_RELEASE:=1
PKG_USE_MIPS16:=0
@@ -24,7 +24,7 @@ PKG_SOURCE_URL:= \
http://gd.tuwien.ac.at/infosys/security/openssl/source/ \
http://www.openssl.org/source/ \
http://www.openssl.org/source/old/$(PKG_BASE)/
-PKG_HASH:=5744cfcbcec2b1b48629f7354203bc1e5e9b5466998bbccc5b5fcde3b18eb684
+PKG_HASH:=ae51d08bba8a83958e894946f15303ff894d75c2b8bbd44a852b64e3fe11d0d6
PKG_LICENSE:=OpenSSL
PKG_LICENSE_FILES:=LICENSE
diff --git a/package/libs/openssl/patches/200-parallel_build.patch b/package/libs/openssl/patches/200-parallel_build.patch
index 37134e4030..cbe5d51241 100644
--- a/package/libs/openssl/patches/200-parallel_build.patch
+++ b/package/libs/openssl/patches/200-parallel_build.patch
@@ -92,7 +92,7 @@
fi; \
--- a/crypto/Makefile
+++ b/crypto/Makefile
-@@ -85,11 +85,11 @@ testapps:
+@@ -87,11 +87,11 @@ testapps:
@if [ -z "$(THIS)" ]; then $(MAKE) -f $(TOP)/Makefile reflect THIS=$@; fi
subdirs:
@@ -106,7 +106,7 @@
links:
@$(PERL) $(TOP)/util/mklink.pl ../include/openssl $(EXHEADER)
-@@ -100,7 +100,7 @@ links:
+@@ -102,7 +102,7 @@ links:
# lib: $(LIB): are splitted to avoid end-less loop
lib: $(LIB)
@touch lib
@@ -115,7 +115,7 @@
$(AR) $(LIB) $(LIBOBJ)
test -z "$(FIPSLIBDIR)" || $(AR) $(LIB) $(FIPSLIBDIR)fipscanister.o
$(RANLIB) $(LIB) || echo Never mind.
-@@ -111,7 +111,7 @@ shared: buildinf.h lib subdirs
+@@ -113,7 +113,7 @@ shared: buildinf.h lib subdirs
fi
libs:
@@ -124,7 +124,7 @@
install:
@[ -n "$(INSTALLTOP)" ] # should be set by top Makefile...
-@@ -120,7 +120,7 @@ install:
+@@ -122,7 +122,7 @@ install:
(cp $$i $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i; \
chmod 644 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i ); \
done;