aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2017-08-30 21:09:17 +0100
committerJohn Crispin <john@phrozen.org>2017-08-31 19:14:52 +0200
commit3435de8c166c0ee2a190bc235658a05c0be588be (patch)
treec9301255b70c39a3adeabe67b052e59ae261f806
parent61027e343025b5f47e7e79db71576e6bd5e97c1d (diff)
downloadupstream-3435de8c166c0ee2a190bc235658a05c0be588be.tar.gz
upstream-3435de8c166c0ee2a190bc235658a05c0be588be.tar.bz2
upstream-3435de8c166c0ee2a190bc235658a05c0be588be.zip
kernel: update 4.4 to 4.4.85
Refresh patches Compile & run tested: ar71xx - Archer C7 v2 Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index da10076218..0ed92dccae 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,11 +3,11 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .83
+LINUX_VERSION-4.4 = .85
LINUX_VERSION-4.9 = .45
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.83 = 5b5f0a0a6cdadcbe5e1c1c057470bb42880590fc97edee299fb1833d646856b4
+LINUX_KERNEL_HASH-4.4.85 = cfa49f631587e4587ba04236ce0e56765ea938c26815d5a29eec561b21d0f055
LINUX_KERNEL_HASH-4.9.45 = 66e5d18dc79a59606b270a1e221a0a80ac09a9e5cd13b1a8b608c514ae15666d
ifdef KERNEL_PATCHVER
diff --git a/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
index 487e896718..5bedf5dc9e 100644
--- a/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
@@ -838,7 +838,7 @@
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3819,14 +3819,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3818,14 +3818,16 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);