aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-08-05 10:42:00 +0000
committerJohn Crispin <john@openwrt.org>2013-08-05 10:42:00 +0000
commit288adb663424bc6098c4485549552a5f78283873 (patch)
tree068ebfecefd86d9a8d1d0e664d11285d6377c536
parent553a46972830d8a0eff4265eed150da49f050634 (diff)
downloadupstream-288adb663424bc6098c4485549552a5f78283873.tar.gz
upstream-288adb663424bc6098c4485549552a5f78283873.tar.bz2
upstream-288adb663424bc6098c4485549552a5f78283873.zip
lantiq: several a803 related fixes
based on work from Matti Laasko that he posted in the wiki Signed-off-by: John Crispin <blogic@openwrt.or SVN-Revision: 37704
-rw-r--r--target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom2
-rwxr-xr-xtarget/linux/lantiq/base-files/etc/uci-defaults/02_network2
-rw-r--r--target/linux/lantiq/dts/ARV752DPW22.dts20
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk2
4 files changed, 16 insertions, 10 deletions
diff --git a/target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index 3f9282805d..7ec8d6fd21 100644
--- a/target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -29,7 +29,7 @@ case "$FIRMWARE" in
"RT2860.eeprom" )
local board=$(lantiq_board_id)
case $board in
- ARV7525PW|ARV752DPW)
+ ARV7525PW|ARV752DPW|ARV752DPW22)
rt2x00_eeprom_extract "board_config" 1040 512
;;
*)
diff --git a/target/linux/lantiq/base-files/etc/uci-defaults/02_network b/target/linux/lantiq/base-files/etc/uci-defaults/02_network
index 1d3a1177b0..f5401c3edd 100755
--- a/target/linux/lantiq/base-files/etc/uci-defaults/02_network
+++ b/target/linux/lantiq/base-files/etc/uci-defaults/02_network
@@ -58,7 +58,7 @@ ACMP252|GIGASX76X)
;;
# ar8316
-ARV4519PW|ARV7518PW)
+ARV4519PW|ARV7518PW|ARV752DPW22)
ucidef_set_interface_lan "eth0.1"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "0t 2 3 4 5"
diff --git a/target/linux/lantiq/dts/ARV752DPW22.dts b/target/linux/lantiq/dts/ARV752DPW22.dts
index a9b1ae039a..983386dc26 100644
--- a/target/linux/lantiq/dts/ARV752DPW22.dts
+++ b/target/linux/lantiq/dts/ARV752DPW22.dts
@@ -31,19 +31,19 @@
partition@0 {
label = "uboot";
- reg = <0x00000 0x10000>;
+ reg = <0x00000 0x30000>;
read-only;
};
partition@10000 {
label = "uboot_env";
- reg = <0x10000 0x10000>;
+ reg = <0x30000 0x10000>;
read-only;
};
partition@20000 {
label = "linux";
- reg = <0x20000 0x7d0000>;
+ reg = <0x40000 0x7b0000>;
};
partition@7f0000 {
@@ -86,26 +86,32 @@
lantiq,output = <0>;
};
pci_in {
- lantiq,groups = "req1", "req2";
+ lantiq,groups = "req1";
lantiq,function = "pci";
- lantiq,open-drain = <1>;
lantiq,pull = <2>;
lantiq,output = <0>;
};
pci_out {
lantiq,groups = "gnt1";
lantiq,function = "pci";
+ lantiq,open-drain = <1>;
lantiq,output = <1>;
};
pci_rst {
lantiq,pins = "io21";
- lantiq,pull = <2>;
+ lantiq,open-drain = <1>;
lantiq,output = <1>;
};
leds {
lantiq,pins = "io3", "io5", "io6", "io8";
+ lantiq,open-drain = <1>;
lantiq,output = <1>;
};
+ buttons {
+ lantiq,pins = "io11", "io12", "io13", "io28";
+ lantiq,pull = <2>;
+ lantiq,output = <0>;
+ };
};
};
@@ -115,7 +121,7 @@
};
etop@E180000 {
- phy-mode = "rmii";
+ phy-mode = "mii";
};
pci@E105400 {
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index 797969a3b0..4528741ea0 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -116,7 +116,7 @@ $(eval $(call Profile,ARV752DPW))
define Profile/ARV752DPW22
NAME:=Easybox 803 - ARV752DPW22
- PACKAGES:=kmod-usb2 kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ PACKAGES:=kmod-usb2-pci kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
ltq-adsl-app ppp-mod-pppoa \