aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-08-08 21:16:02 +0200
committerPetr Štetiar <ynezz@true.cz>2019-11-09 08:31:04 +0100
commit05c858ff6af406de5de18c8459368551c6fd2833 (patch)
tree42d773a126c40e4b236bb27360ae2e369c115a9d
parentc1d19b37d5ccda858c24b5ab4f7ad9ba30552c5a (diff)
downloadupstream-05c858ff6af406de5de18c8459368551c6fd2833.tar.gz
upstream-05c858ff6af406de5de18c8459368551c6fd2833.tar.bz2
upstream-05c858ff6af406de5de18c8459368551c6fd2833.zip
sdk: fix GCC and Python dangling symlinks
Force prereq again in SDK in order to fix GCC and Python dangling symlinks: staging_dir/host/bin/g++ -> /builder/ath79_generic/ccache_cxx.sh staging_dir/host/bin/gcc -> /builder/ath79_generic/ccache_cc.sh staging_dir/host/bin/python -> /usr/bin/python3.5 staging_dir/host/bin/python3 -> /usr/bin/python3.5 Ref: FS#2424 Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 200f2666fb1c8d9d128824dc5586e0e66386971f)
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 95ac3be197..cecf70df91 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -135,7 +135,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
-rm -rf \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/ccache \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/ccache \
- $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/.prereq-build
-rm -f $(SDK_BUILD_DIR)/feeds.conf.default
$(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)