aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosy Song <rosysong@rosinson.com>2018-07-31 17:09:34 +0800
committerJohn Crispin <john@phrozen.org>2018-08-01 11:25:04 +0200
commitf30583c41d37c39d3ca063b31871a3c207734b1f (patch)
tree63aa87539ee6924ea24c986592bd41b9dea24e42
parent0b7a9688ce49c60a18575b925138b100f4e8e078 (diff)
downloadupstream-f30583c41d37c39d3ca063b31871a3c207734b1f.tar.gz
upstream-f30583c41d37c39d3ca063b31871a3c207734b1f.tar.bz2
upstream-f30583c41d37c39d3ca063b31871a3c207734b1f.zip
nftables: allow to build with json support
Signed-off-by: Rosy Song <rosysong@rosinson.com>
-rw-r--r--package/network/utils/nftables/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index f3bdc5caee..d1e995116d 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -34,10 +34,21 @@ define Package/nftables
CATEGORY:=Network
SUBMENU:=Firewall
TITLE:=nftables packet filtering userspace utility
- DEPENDS:=+kmod-nft-core +libnftnl
+ DEPENDS:=+kmod-nft-core +libnftnl +PACKAGE_NFT_WITH_JSON:jansson
URL:=http://netfilter.org/projects/nftables/
endef
+define Package/nftables/config
+ config PACKAGE_NFT_WITH_JSON
+ bool "Build nftables with json support"
+ depends on PACKAGE_nftables
+ default n
+endef
+
+ifeq ($(CONFIG_PACKAGE_NFT_WITH_JSON),y)
+CONFIGURE_ARGS += --with-json
+endif
+
define Package/nftables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/