aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-08-08 00:47:12 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-08-08 00:48:53 +0200
commitec78f03de589adc9bd47a02d723d7054510601dd (patch)
tree3cf079a036ee581017a4b49b25d5a5b2a5637ed8
parent848b455d2e9441361f6e010f9b95ab8a7dccbae1 (diff)
downloadupstream-ec78f03de589adc9bd47a02d723d7054510601dd.tar.gz
upstream-ec78f03de589adc9bd47a02d723d7054510601dd.tar.bz2
upstream-ec78f03de589adc9bd47a02d723d7054510601dd.zip
image: fix build without ucert
Make sure the Shell-expression returns true also in case of key-build.ucert being absent. Fixes commit 848b455d2e ("image: use ucert to append signature") Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 01040138a4..f7e6ba6aa6 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -309,7 +309,7 @@ metadata_json = \
define Build/append-metadata
$(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
- [ -s "$(BUILD_KEY)" -a -s "$(BUILD_KEY).ucert" ] && { \
+ [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" ] || { \
cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
ucert -A -c "$@.ucert" -x "$@.sig" ;\