aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-08-09 17:42:35 +0200
committerHans Dedecker <dedeckeh@gmail.com>2018-08-09 17:48:03 +0200
commite0fbf62821eb2d06badf393ac2c62570aaf85ccd (patch)
treef6b00a334a629aca49637b9dc618e3f0e0786971
parent6579af7a77430ccac3a557ecb36addade6774e76 (diff)
downloadupstream-e0fbf62821eb2d06badf393ac2c62570aaf85ccd.tar.gz
upstream-e0fbf62821eb2d06badf393ac2c62570aaf85ccd.tar.bz2
upstream-e0fbf62821eb2d06badf393ac2c62570aaf85ccd.zip
iproute2: remove libutil from InstallDev section
Commit 4d961538f6 added libutil to the iproute2 InstallDev section but lead to compile issues with packages picking up the wrong libutil since libutil is quite a generic name ... Further libutil is rather meant for internal usage in iproute2 than a public API; therefore let's remove it from the InstallDev section together with ll_map.h Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-rw-r--r--package/network/utils/iproute2/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 679c0c2a2b..800a23ee0e 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.17.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
@@ -132,10 +132,9 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_BUILD_DIR)/include/{libgenl,libnetlink,ll_map}.h $(1)/usr/include/
+ $(CP) $(PKG_BUILD_DIR)/include/{libgenl,libnetlink}.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
- $(CP) $(PKG_BUILD_DIR)/lib/libutil.a $(1)/usr/lib/
endef
define Package/ip-tiny/install