aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-07-29 11:55:16 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 08:12:13 +0200
commitcff6548948f76b8d0c922ef5e5d456a88a78ab2e (patch)
treedcece3602608f21ebe7f5bfae28ccf89b1563613
parentaed4799d6d05d89dbca1bd5f14cc3d09ac563f3b (diff)
downloadupstream-cff6548948f76b8d0c922ef5e5d456a88a78ab2e.tar.gz
upstream-cff6548948f76b8d0c922ef5e5d456a88a78ab2e.tar.bz2
upstream-cff6548948f76b8d0c922ef5e5d456a88a78ab2e.zip
apm821xx: split MBL's rootfs.img.gz into a sysupgrade and factory image
@vahid-dan reported a issue with extracting the rpi images with Gnome's Archive Manager: "Ubuntu Archive Manager cannot extract the file and it just throws a general error message: "An error occurred while extracting files". <https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi> The MBL's rootfs.img.gz image is generated in much the same way. Hence this patch preemptively splits the rootfs.img.gz image into a sysupgrade and a factory image. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-rw-r--r--target/linux/apm821xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index bfc6562431..00ab19602d 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -224,11 +224,12 @@ define Device/wd_mybooklive
KERNEL := kernel-bin | dtb | gzip | uImage gzip
KERNEL_INITRAMFS := kernel-bin | dtb | gzip | uImage gzip
BOOT_SIZE := 8
- IMAGES := rootfs.img.gz kernel.dtb
+ IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
DEVICE_DTB := apollo3g.dtb
FILESYSTEMS := ext4 squashfs
+ IMAGE/factory.img.gz := boot-script | boot-img | hdd-img | gzip
IMAGE/kernel.dtb := export-dtb
- IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
+ IMAGE/sysupgrade.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
endef
TARGET_DEVICES += wd_mybooklive