aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Tunin <hanipouspilot@gmail.com>2018-08-09 20:49:29 +0300
committerMathias Kresin <dev@kresin.me>2018-08-11 21:45:04 +0200
commit97de133368762824ba3d7e9d95f97011a597ec1a (patch)
treed55d2e625ccfa22b897ae3f3be075a2b2a7cefc8
parenta441c86d93657121afe8117f8329b7095f7154d2 (diff)
downloadupstream-97de133368762824ba3d7e9d95f97011a597ec1a.tar.gz
upstream-97de133368762824ba3d7e9d95f97011a597ec1a.tar.bz2
upstream-97de133368762824ba3d7e9d95f97011a597ec1a.zip
ath79: add support of D-Link DIR-825 B1
Add support for the ar71xx supported D-Link DIR-825 B1 to ath79. Signed-off-by: Dmitry Tunin <hanipouspilot@gmail.com>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network9
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom22
-rw-r--r--target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts247
-rw-r--r--target/linux/ath79/image/generic.mk10
4 files changed, 288 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 79b39b22f4..5edfd9e2ce 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -30,6 +30,11 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "6@eth0"
;;
+ dlink,dir-825-b1)
+ ucidef_set_interface_wan "eth1"
+ ucidef_add_switch "switch0" \
+ "0:lan" "1:lan" "2:lan" "3:lan" "5@eth0"
+ ;;
embeddedwireless,dorin)
ucidef_add_switch "switch0" \
"0@eth0" "1:wan" "2:lan:3" "3:lan:2"
@@ -143,6 +148,10 @@ ath79_setup_macs()
avm,fritz300e)
lan_mac=$(fritz_tffs -n maca -i $(find_mtd_part "tffs (1)"))
;;
+ dlink,dir-825-b1)
+ lan_mac=$(mtd_get_mac_text "caldata" 65440)
+ wan_mac=$(mtd_get_mac_text "caldata" 65460)
+ ;;
phicomm,k2t)
lan_mac=$(k2t_get_mac "lan_mac")
wan_mac=$(k2t_get_mac "wan_mac")
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index cd8f19be39..9577859548 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -129,4 +129,26 @@ case "$FIRMWARE" in
;;
esac
;;
+"ath9k-eeprom-pci-0000:00:11.0.bin")
+ case $board in
+ dlink,dir-825-b1)
+ ath9k_eeprom_extract "caldata" 4096 3768
+ ath9k_patch_fw_mac_crc $(mtd_get_mac_text "caldata" 65440) 524
+ ;;
+ *)
+ ath9k_eeprom_die "board $board is not supported yet"
+ ;;
+ esac
+ ;;
+"ath9k-eeprom-pci-0000:00:12.0.bin")
+ case $board in
+ dlink,dir-825-b1)
+ ath9k_eeprom_extract "caldata" 20480 3768
+ ath9k_patch_fw_mac_crc $(macaddr_add $(mtd_get_mac_text "caldata" 65460) 1) 524
+ ;;
+ *)
+ ath9k_eeprom_die "board $board is not supported yet"
+ ;;
+ esac
+ ;;
esac
diff --git a/target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts b/target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts
new file mode 100644
index 0000000000..489f4a4072
--- /dev/null
+++ b/target/linux/ath79/dts/ar7161_dlink_dir-825-b1.dts
@@ -0,0 +1,247 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7100.dtsi"
+
+/ {
+ compatible = "dlink,dir-825-b1", "qca,ar7161";
+ model = "D-Link DIR825B1";
+
+ aliases {
+ led-status = &orange_power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ extosc: ref {
+ compatible = "fixed-clock";
+ #clock-cells = <0>;
+ clock-output-names = "ref";
+ clock-frequency = <40000000>;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+ blue_usb {
+ label = "d-link:blue:usb";
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ trigger-sources = <&usb_ochi_port>, <&usb_echi_port>;
+ linux,default-trigger = "usbport";
+ };
+
+ orange_power: orange_power {
+ label = "d-link:orange:power";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ };
+
+ blue_power {
+ label = "d-link:blue:power";
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ blue_wps {
+ label = "d-link:blue:wps";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ orange_planet {
+ label = "d-link:orange:planet";
+ gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+
+ blue_planet {
+ label = "d-link:blue:planet";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+ };
+
+ ath9k-leds {
+ compatible = "gpio-leds";
+
+ wlan2g {
+ label = "d-link:blue:wlan2g";
+ gpios = <&ath9k0 5 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g {
+ label = "d-link:blue:wlan5g";
+ gpios = <&ath9k1 5 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ linux,default-trigger = "phy1tpt";
+ };
+
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "wps";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ rtl8366s {
+ compatible = "realtek,rtl8366s";
+ gpio-sda = <&gpio 5 GPIO_ACTIVE_HIGH>;
+ gpio-sck = <&gpio 7 GPIO_ACTIVE_HIGH>;
+ realtek,initvals = <0x06 0x0108>;
+
+ mdio-bus {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ phy-mask = <0x10>;
+
+ phy4: ethernet-phy@4 {
+ reg = <4>;
+ phy-mode = "rgmii";
+ };
+ };
+
+ };
+};
+
+
+&usb1 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ usb_ochi_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb2 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ usb_echi_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&pcie0 {
+ status = "okay";
+
+ ath9k0: wifi@0,11 {
+ compatible = "pci168c,0029";
+ reg = <0x8800 0 0 0 0>;
+ qca,no-eeprom;
+ #gpio-cells = <2>;
+ gpio-controller;
+ };
+
+ ath9k1: wifi@0,12 {
+ compatible = "pci168c,0029";
+ reg = <0x9000 0 0 0 0>;
+ qca,no-eeprom;
+ #gpio-cells = <2>;
+ gpio-controller;
+ };
+};
+
+&uart {
+ status = "okay";
+};
+
+&pll {
+ clocks = <&extosc>;
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "config";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x050000 0x610000>;
+ };
+
+ caldata: partition@60000 {
+ label = "caldata";
+ reg = <0x660000 0x010000>;
+ read-only;
+ };
+
+ partition@670000 {
+ label = "unknown";
+ reg = <0x670000 0x190000>;
+ read-only;
+ };
+ };
+ };
+};
+
+
+&eth0 {
+ status = "okay";
+ pll-data = <0x11110000 0x00001099 0x00991099>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+
+};
+
+&eth1 {
+ status = "okay";
+ pll-data = <0x11110000 0x00001099 0x00991099>;
+
+ phy-handle = <&phy4>;
+
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 614b3371f3..767d635cfb 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -22,6 +22,16 @@ define Device/buffalo_wzr-hp-g450h
endef
TARGET_DEVICES += buffalo_wzr-hp-g450h
+define Device/dlink_dir-825-b1
+ ATH_SOC := ar7161
+ DEVICE_TITLE := D-LINK DIR-825 B1
+ IMAGE_SIZE := 6208k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport kmod-leds-reset kmod-owl-loader
+ SUPPORTED_DEVICES += dir-825-b1
+endef
+TARGET_DEVICES += dlink_dir-825-b1
+
define Device/embeddedwireless_dorin
ATH_SOC := ar9331
DEVICE_TITLE := Embedded Wireless Dorin