aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-08-07 10:34:37 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-08-07 12:53:47 +0200
commit7a254aeeb8a9ca7e2846af6ed508f5ec21db350d (patch)
tree51591199a678b76a724519391e4bda4921037706
parentf7036a34ace38b701243e9357d7f509f8a66f0b1 (diff)
downloadupstream-7a254aeeb8a9ca7e2846af6ed508f5ec21db350d.tar.gz
upstream-7a254aeeb8a9ca7e2846af6ed508f5ec21db350d.tar.bz2
upstream-7a254aeeb8a9ca7e2846af6ed508f5ec21db350d.zip
kernel: bump 4.14 to 4.14.61
Refreshed all patches. Compile-tested on: cns3xxx, imx6, x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 40f2ed8e40..9ffbb2e306 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .71
LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.14 = .60
LINUX_VERSION-4.9 = .118
+LINUX_VERSION-4.14 = .61
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.14.60 = 6ce143258fba2e1f543ff56802e047d7d3a741f746b9c947dd088d4a2873b295
LINUX_KERNEL_HASH-4.9.118 = 7df789e40c6040cd6f6e34326f477b389ab7eaf2bb04940fca4bbe5e733add57
+LINUX_KERNEL_HASH-4.14.61 = 0d0ec521a771e7d393f25b789a06d9af6e2a5a4837fadc04e7048e03b41c70e8
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch b/target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch
index 5c4edec077..926e0d8421 100644
--- a/target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch
+++ b/target/linux/mediatek/patches-4.14/0033-dsa-multi-cpu.patch
@@ -249,7 +249,7 @@
--- a/net/dsa/slave.c
+++ b/net/dsa/slave.c
-@@ -1257,7 +1257,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1263,7 +1263,7 @@ int dsa_slave_create(struct dsa_port *po
int ret;
cpu_dp = ds->dst->cpu_dp;
@@ -258,7 +258,7 @@
if (!ds->num_tx_queues)
ds->num_tx_queues = 1;
-@@ -1295,6 +1295,7 @@ int dsa_slave_create(struct dsa_port *po
+@@ -1301,6 +1301,7 @@ int dsa_slave_create(struct dsa_port *po
p->dp = port;
INIT_LIST_HEAD(&p->mall_tc_list);
p->xmit = dst->tag_ops->xmit;