aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit18a2595315b2f123cc449f875a642857aee102b5 (patch)
tree7243eefeb81170932914d57ddda64aa98e80ef24
parent2d5fee248c5bcc47de529fbf798a3ca07eefa6a4 (diff)
downloadupstream-18a2595315b2f123cc449f875a642857aee102b5.tar.gz
upstream-18a2595315b2f123cc449f875a642857aee102b5.tar.bz2
upstream-18a2595315b2f123cc449f875a642857aee102b5.zip
ath79: rename tl-archer-c7 to archer-c7
This router is called Archer C7 and the tl was used to identify TP-LINK. Since we have added tplink in dts/board name, the tl prefix is useless now. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata8
-rw-r--r--target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts (renamed from target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts)4
-rw-r--r--target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi (renamed from target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi)0
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk4
5 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index d88a0f368a..f0233b4b28 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -64,7 +64,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "3:lan:1" "5:lan:2" "4:wan"
;;
- tplink,tl-archer-c7-v2)
+ tplink,archer-c7-v2)
ucidef_add_switch "switch0" \
"0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 0d58ea0dd4..038573f3e8 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -91,13 +91,13 @@ case "$FIRMWARE" in
ath10kcal_extract "ART" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
;;
- tplink,re450-v2)
+ tplink,archer-c7-v2)
ath10kcal_extract "art" 20480 2116
- ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
+ ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
;;
- tplink,tl-archer-c7-v2)
+ tplink,re450-v2)
ath10kcal_extract "art" 20480 2116
- ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
+ ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
;;
ubnt,unifiac-lite|\
ubnt,unifiac-mesh|\
diff --git a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts b/target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts
index e096db7485..10e7a65e81 100644
--- a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7-v2.dts
+++ b/target/linux/ath79/dts/qca9558_tplink_archer-c7-v2.dts
@@ -4,10 +4,10 @@
#include <dt-bindings/gpio/gpio.h>
#include <dt-bindings/input/input.h>
-#include "qca9558_tplink_tl-archer-c7.dtsi"
+#include "qca9558_tplink_archer-c7.dtsi"
/ {
- compatible = "tplink,tl-archer-c7-v2", "qca,qca9558";
+ compatible = "tplink,archer-c7-v2", "qca,qca9558";
model = "TP-Link Archer C7 Version 2";
};
diff --git a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi b/target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi
index 6fb25a9d2e..6fb25a9d2e 100644
--- a/target/linux/ath79/dts/qca9558_tplink_tl-archer-c7.dtsi
+++ b/target/linux/ath79/dts/qca9558_tplink_archer-c7.dtsi
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 49b28f7599..6c9e7879cb 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -1,6 +1,6 @@
include ./common-tp-link.mk
-define Device/tplink_tl-archer-c7-v2
+define Device/tplink_archer-c7-v2
$(Device/tplink-16mlzma)
ATH_SOC := qca9558
DEVICE_TITLE := TP-LINK Archer C7 v2
@@ -10,7 +10,7 @@ define Device/tplink_tl-archer-c7-v2
IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
endef
-TARGET_DEVICES += tplink_tl-archer-c7-v2
+TARGET_DEVICES += tplink_archer-c7-v2
define Device/tplink_tl-re450-v2
$(Device/tplink)