aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2018-08-11 16:01:56 -0400
committerJohn Crispin <john@phrozen.org>2018-08-13 08:43:58 +0200
commit09ac4aa86b889446969df10e397798c7fe961515 (patch)
tree1444e3ec5e7ce0d29f1b3505b1b3ec13c068b18f
parent7d1b742b4d18636b26b09142b7265215bf4eff32 (diff)
downloadupstream-09ac4aa86b889446969df10e397798c7fe961515.tar.gz
upstream-09ac4aa86b889446969df10e397798c7fe961515.tar.bz2
upstream-09ac4aa86b889446969df10e397798c7fe961515.zip
uboot-zynq: update to 2018.07
Signed-off-by: Luis Araneda <luaraneda@gmail.com>
-rw-r--r--package/boot/uboot-zynq/Makefile4
-rw-r--r--package/boot/uboot-zynq/patches/020-v2018.09-arm-zynq-dts-add-spi-flash-node-to-zedboard.patch43
-rw-r--r--package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch2
3 files changed, 46 insertions, 3 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index f2c0769ead..ac4503af50 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2017.03
+PKG_VERSION:=2018.07
-PKG_HASH:=f54baf3f9325bf444c7905f3a5b6f83680edb1e6e1a4d5f8a5ad80abe885113f
+PKG_HASH:=9f10df88bc91b35642e461217f73256bbaeeca9ae2db8db56197ba5e89e1f6d4
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/u-boot.mk
diff --git a/package/boot/uboot-zynq/patches/020-v2018.09-arm-zynq-dts-add-spi-flash-node-to-zedboard.patch b/package/boot/uboot-zynq/patches/020-v2018.09-arm-zynq-dts-add-spi-flash-node-to-zedboard.patch
new file mode 100644
index 0000000000..71be68ad65
--- /dev/null
+++ b/package/boot/uboot-zynq/patches/020-v2018.09-arm-zynq-dts-add-spi-flash-node-to-zedboard.patch
@@ -0,0 +1,43 @@
+From a492fdffa3c86f6b8420b6433a2ce07271597324 Mon Sep 17 00:00:00 2001
+From: Luis Araneda <luaraneda@gmail.com>
+Date: Fri, 27 Jul 2018 04:43:42 -0400
+Subject: [PATCH] arm: zynq: dts: add spi flash node to zedboard
+
+Add a flash node to fix the detection of the memory IC.
+With the changes introduced with commit 8fee8845e754
+("enf_sf: reuse setup_flash_device instead of open coding it")
+the SPI speed is now read from device-tree or a default value
+is applied. This replaced the old behavior of setting the
+SPI speed to CONFIG_ENV_SPI_MAX_HZ.
+
+As this board didn't have a flash node, the default value
+was applied to the SPI speed, producing an error when probing
+the flash memory (speed too slow).
+
+Signed-off-by: Luis Araneda <luaraneda@gmail.com>
+Signed-off-by: Michal Simek <michal.simek@xilinx.com>
+---
+ arch/arm/dts/zynq-zed.dts | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/arch/arm/dts/zynq-zed.dts b/arch/arm/dts/zynq-zed.dts
+index 24eccf1633..9c505fb7b8 100644
+--- a/arch/arm/dts/zynq-zed.dts
++++ b/arch/arm/dts/zynq-zed.dts
+@@ -51,6 +51,13 @@
+ &qspi {
+ u-boot,dm-pre-reloc;
+ status = "okay";
++ num-cs = <1>;
++ flash@0 {
++ compatible = "spansion,s25fl256s", "spi-flash";
++ reg = <0>;
++ spi-max-frequency = <30000000>;
++ m25p,fast-read;
++ };
+ };
+
+ &sdhci0 {
+--
+2.18.0
+
diff --git a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
index 3a32ea1eb9..6fe253606e 100644
--- a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
+++ b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
@@ -3,7 +3,7 @@ needed dependencies are added too.
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -152,7 +152,7 @@ endif
+@@ -146,7 +146,7 @@ endif
# MXSImage needs LibSSL
ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
HOSTLOADLIBES_mkimage += \