aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-18 13:00:03 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-12-18 14:24:57 +0100
commitdd0a213bedd2f751fef1b1b9212192b31b92dee5 (patch)
tree86dfc3b36e61999513aba5d9e7adfbfa4756eba3
parent902a9f23d61263e9d9671465b2d24ac6a3962278 (diff)
downloadupstream-dd0a213bedd2f751fef1b1b9212192b31b92dee5.tar.gz
upstream-dd0a213bedd2f751fef1b1b9212192b31b92dee5.tar.bz2
upstream-dd0a213bedd2f751fef1b1b9212192b31b92dee5.zip
kernel: bump 4.9 to 4.9.146
Refreshed all patches. Compile-tested on: brcm2708 Runtime-tested on: brcm2708 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com> Tested-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.9/950-0055-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch3
-rw-r--r--target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch2
-rw-r--r--target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch4
-rw-r--r--target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch2
5 files changed, 8 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index ae57860803..543eb8768a 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,12 +3,12 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .130
-LINUX_VERSION-4.9 = .145
+LINUX_VERSION-4.9 = .146
LINUX_VERSION-4.14 = .88
LINUX_VERSION-4.19 = .9
LINUX_KERNEL_HASH-3.18.130 = d1bf85ed3fd0067b1134178ed5492ae0053cb3fdd5361986fe0b85234fc82723
-LINUX_KERNEL_HASH-4.9.145 = 6901ca37e8c305a2f26c598952338b4dc2481ca5a9d0bf71e2b71730a5b5bc5e
+LINUX_KERNEL_HASH-4.9.146 = 58195a8be3085d117c83a2ed1caa3b46ea7c1614c75f951b9f13f7adb03f8e59
LINUX_KERNEL_HASH-4.14.88 = b0f0b8c76708eab6caf3009702e531d40a243b152922ee1f9a441316f226f52d
LINUX_KERNEL_HASH-4.19.9 = fc116cc6829c73944215d3b3ac0fc368dde9e8235b456744afffde001269dbf2
diff --git a/target/linux/brcm2708/patches-4.9/950-0055-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch b/target/linux/brcm2708/patches-4.9/950-0055-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
index 725ac70e44..a5e7dee6f4 100644
--- a/target/linux/brcm2708/patches-4.9/950-0055-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
+++ b/target/linux/brcm2708/patches-4.9/950-0055-BCM270x_DT-Add-pwr_led-and-the-required-input-trigge.patch
@@ -89,12 +89,13 @@ See: https://github.com/raspberrypi/linux/issues/1064
depends on LEDS_TRIGGERS
--- a/drivers/leds/trigger/Makefile
+++ b/drivers/leds/trigger/Makefile
-@@ -9,4 +9,5 @@ obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtr
+@@ -9,5 +9,6 @@ obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtr
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
obj-$(CONFIG_LEDS_TRIGGER_CAMERA) += ledtrig-camera.o
+obj-$(CONFIG_LEDS_TRIGGER_INPUT) += ledtrig-input.o
obj-$(CONFIG_LEDS_TRIGGER_PANIC) += ledtrig-panic.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
--- /dev/null
+++ b/drivers/leds/trigger/ledtrig-input.c
@@ -0,0 +1,54 @@
diff --git a/target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch b/target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
index 4a3f355b4d..0a5b9ead9d 100644
--- a/target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
+++ b/target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
if (tcp_small_queue_check(sk, skb, 0))
break;
-@@ -3542,8 +3542,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3546,8 +3546,6 @@ void __tcp_send_ack(struct sock *sk, u32
/* We do not want pure acks influencing TCP Small Queues or fq/pacing
* too much.
* SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
diff --git a/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch b/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
index 8a431a02e2..1e33604f6a 100644
--- a/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
@@ -1370,7 +1370,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
&queue_tx_maxrate.attr,
--- a/net/core/rtnetlink.c
+++ b/net/core/rtnetlink.c
-@@ -3706,7 +3706,7 @@ static int rtnl_get_offload_stats(struct
+@@ -3709,7 +3709,7 @@ static int rtnl_get_offload_stats(struct
if (!size)
continue;
@@ -1379,7 +1379,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
continue;
attr = nla_reserve_64bit(skb, attr_id, size,
-@@ -3747,7 +3747,7 @@ static int rtnl_get_offload_stats_size(c
+@@ -3750,7 +3750,7 @@ static int rtnl_get_offload_stats_size(c
for (attr_id = IFLA_OFFLOAD_XSTATS_FIRST;
attr_id <= IFLA_OFFLOAD_XSTATS_MAX; attr_id++) {
diff --git a/target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch b/target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch
index 4124bab4ad..9c23279188 100644
--- a/target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.9/703-phy-support-layerscape.patch
@@ -1713,7 +1713,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
ret = phydrv->resume(phydev);
if (ret)
-@@ -1723,7 +1723,7 @@ static int phy_remove(struct device *dev
+@@ -1720,7 +1720,7 @@ static int phy_remove(struct device *dev
phydev->state = PHY_DOWN;
mutex_unlock(&phydev->lock);