aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-01-18 23:32:01 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-18 19:39:05 +0100
commitc26b687e31b788433091a98b65ddc984e2d227c8 (patch)
treec1490a3958570ceef516362f10a7859296f45681
parent8d78354d245886d5367990d29750fadee0573754 (diff)
downloadupstream-c26b687e31b788433091a98b65ddc984e2d227c8.tar.gz
upstream-c26b687e31b788433091a98b65ddc984e2d227c8.tar.bz2
upstream-c26b687e31b788433091a98b65ddc984e2d227c8.zip
kernel: remove further obsolete kernel version switches
Most of the kernel version switches below 4.14 were removed in commit 97940f876616 ("kernel: remove obsolete kernel version switches"), but some of them still remained. Remove them now. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
-rw-r--r--include/image.mk19
-rw-r--r--include/target.mk4
-rw-r--r--package/kernel/linux/modules/other.mk5
-rw-r--r--target/linux/bcm53xx/modules.mk8
4 files changed, 10 insertions, 26 deletions
diff --git a/include/image.mk b/include/image.mk
index 26da4d6819..46d592e8dc 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -157,18 +157,13 @@ endif
# Disable noisy checks by default as in upstream
-ifeq ($(strip $(call kernel_patchver_ge,4.7.0)),1)
- DTC_FLAGS += -Wno-unit_address_vs_reg
-endif
-ifeq ($(strip $(call kernel_patchver_ge,4.12.0)),1)
- DTC_FLAGS += \
- -Wno-unit_address_vs_reg \
- -Wno-simple_bus_reg \
- -Wno-unit_address_format \
- -Wno-pci_bridge \
- -Wno-pci_device_bus_num \
- -Wno-pci_device_reg
-endif
+DTC_FLAGS += \
+ -Wno-unit_address_vs_reg \
+ -Wno-simple_bus_reg \
+ -Wno-unit_address_format \
+ -Wno-pci_bridge \
+ -Wno-pci_device_bus_num \
+ -Wno-pci_device_reg
ifeq ($(strip $(call kernel_patchver_ge,4.17.0)),1)
DTC_FLAGS += \
-Wno-avoid_unnecessary_addr_size \
diff --git a/include/target.mk b/include/target.mk
index a813ba2d2d..9bd4c14936 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -51,10 +51,6 @@ else
endif
endif
-ifneq ($(filter 4.9,$(KERNEL_PATCHVER)),)
- DEFAULT_PACKAGES.router:=$(filter-out kmod-ipt-offload,$(DEFAULT_PACKAGES.router))
-endif
-
# Add device specific packages (here below to allow device type set from subtarget)
DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 3ba9bdb82c..b65d0155db 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -53,11 +53,8 @@ define KernelPackage/bluetooth
$(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
- $(LINUX_DIR)/drivers/bluetooth/btusb.ko
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,4.1.0)),1)
- FILES+= \
+ $(LINUX_DIR)/drivers/bluetooth/btusb.ko \
$(LINUX_DIR)/drivers/bluetooth/btintel.ko
-endif
AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
endef
diff --git a/target/linux/bcm53xx/modules.mk b/target/linux/bcm53xx/modules.mk
index 2a3149b37b..b3bb42578c 100644
--- a/target/linux/bcm53xx/modules.mk
+++ b/target/linux/bcm53xx/modules.mk
@@ -9,9 +9,7 @@ define KernelPackage/phy-bcm-ns-usb2
KCONFIG:=CONFIG_PHY_BCM_NS_USB2
DEPENDS:=@TARGET_bcm53xx
SUBMENU:=$(USB_MENU)
- FILES:=\
- $(LINUX_DIR)/drivers/phy/phy-bcm-ns-usb2.ko@lt4.13 \
- $(LINUX_DIR)/drivers/phy/broadcom/phy-bcm-ns-usb2.ko@gt4.13
+ FILES:=$(LINUX_DIR)/drivers/phy/broadcom/phy-bcm-ns-usb2.ko
AUTOLOAD:=$(call AutoLoad,45,phy-bcm-ns-usb2,1)
endef
@@ -27,9 +25,7 @@ define KernelPackage/phy-bcm-ns-usb3
KCONFIG:=CONFIG_PHY_BCM_NS_USB3
DEPENDS:=@TARGET_bcm53xx
SUBMENU:=$(USB_MENU)
- FILES:=\
- $(LINUX_DIR)/drivers/phy/phy-bcm-ns-usb3.ko@lt4.13 \
- $(LINUX_DIR)/drivers/phy/broadcom/phy-bcm-ns-usb3.ko@ge4.13
+ FILES:=$(LINUX_DIR)/drivers/phy/broadcom/phy-bcm-ns-usb3.ko
AUTOLOAD:=$(call AutoLoad,45,phy-bcm-ns-usb3,1)
endef