aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
commit7d73153e86c9c139f34467c30bda3f7e498834a1 (patch)
tree5bbf09f1d209cb2513b4c3584ff064681a6e563a
parent35d2b601aa7737c5eebe8557bd4cb056e52b2f5d (diff)
downloadupstream-7d73153e86c9c139f34467c30bda3f7e498834a1.tar.gz
upstream-7d73153e86c9c139f34467c30bda3f7e498834a1.tar.bz2
upstream-7d73153e86c9c139f34467c30bda3f7e498834a1.zip
kernel: allow hwmon GSC driver for all targets
- enable using hwmon GSC driver on all targets - add a kmod package for it Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 37933
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
-rw-r--r--target/linux/generic/patches-3.10/880-gateworks_system_controller.patch2
-rw-r--r--target/linux/generic/patches-3.3/880-gateworks_system_controller.patch2
-rw-r--r--target/linux/generic/patches-3.6/880-gateworks_system_controller.patch2
-rw-r--r--target/linux/generic/patches-3.8/880-gateworks_system_controller.patch2
-rw-r--r--target/linux/generic/patches-3.9/880-gateworks_system_controller.patch2
6 files changed, 20 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5af311df66..b1f4744330 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+ TITLE:=Gateworks GSC monitoring support
+ KCONFIG:=CONFIG_SENSORS_GSC
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+ AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+ Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))
diff --git a/target/linux/generic/patches-3.10/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.10/880-gateworks_system_controller.patch
index 73dd583911..d923485020 100644
--- a/target/linux/generic/patches-3.10/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.10/880-gateworks_system_controller.patch
@@ -6,7 +6,7 @@
+config SENSORS_GSC
+ tristate "Gateworks System Controller"
-+ depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++ depends on I2C
+ help
+ If you say yes here you get support for the Gateworks System Controller.
+
diff --git a/target/linux/generic/patches-3.3/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.3/880-gateworks_system_controller.patch
index 981610dad1..d9a64810d9 100644
--- a/target/linux/generic/patches-3.3/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.3/880-gateworks_system_controller.patch
@@ -6,7 +6,7 @@
+config SENSORS_GSC
+ tristate "Gateworks System Controller"
-+ depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++ depends on I2C
+ help
+ If you say yes here you get support for the Gateworks System Controller.
+
diff --git a/target/linux/generic/patches-3.6/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.6/880-gateworks_system_controller.patch
index 02c9d8f9aa..010dc29576 100644
--- a/target/linux/generic/patches-3.6/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.6/880-gateworks_system_controller.patch
@@ -6,7 +6,7 @@
+config SENSORS_GSC
+ tristate "Gateworks System Controller"
-+ depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++ depends
+ help
+ If you say yes here you get support for the Gateworks System Controller.
+
diff --git a/target/linux/generic/patches-3.8/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.8/880-gateworks_system_controller.patch
index dd78ef8d07..1ec096062b 100644
--- a/target/linux/generic/patches-3.8/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.8/880-gateworks_system_controller.patch
@@ -6,7 +6,7 @@
+config SENSORS_GSC
+ tristate "Gateworks System Controller"
-+ depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++ depends on I2C
+ help
+ If you say yes here you get support for the Gateworks System Controller.
+
diff --git a/target/linux/generic/patches-3.9/880-gateworks_system_controller.patch b/target/linux/generic/patches-3.9/880-gateworks_system_controller.patch
index efb7c48aba..3bcca9c192 100644
--- a/target/linux/generic/patches-3.9/880-gateworks_system_controller.patch
+++ b/target/linux/generic/patches-3.9/880-gateworks_system_controller.patch
@@ -6,7 +6,7 @@
+config SENSORS_GSC
+ tristate "Gateworks System Controller"
-+ depends on I2C && (ARCH_DAVINCI || ARCH_CNS3XXX || ARCH_IXP4XX)
++ depends on I2C
+ help
+ If you say yes here you get support for the Gateworks System Controller.
+