aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-03-07 19:33:11 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-03-07 19:34:12 +0100
commit00b319e9be3198eb306bf58577b4e2c6fc86af34 (patch)
treeb5007738b3723859b91145ee0ffc09077677edde
parentdfb7a4ce5d3200c5cb4b12c8a90b2fcc7d66f6bd (diff)
downloadupstream-00b319e9be3198eb306bf58577b4e2c6fc86af34.tar.gz
upstream-00b319e9be3198eb306bf58577b4e2c6fc86af34.tar.bz2
upstream-00b319e9be3198eb306bf58577b4e2c6fc86af34.zip
oxnas: restore accidentally modified patch for kernel 4.14
patches-4.14/340-oxnas-pcie.patch was adapted for kernel 5.4 by accident. Revert that change to restore 4.14 builds. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
index 2a4e4536dc..a6b7137584 100644
--- a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
+++ b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
@@ -1,5 +1,5 @@
---- a/drivers/pci/controller/Kconfig
-+++ b/drivers/pci/controller/Kconfig
+--- a/drivers/pci/host/Kconfig
++++ b/drivers/pci/host/Kconfig
@@ -220,4 +220,9 @@ config VMD
To compile this driver as a module, choose M here: the
module will be called vmd.
@@ -10,8 +10,8 @@
+ select PCIEPORTBUS
+
endmenu
---- a/drivers/pci/controller/Makefile
-+++ b/drivers/pci/controller/Makefile
+--- a/drivers/pci/host/Makefile
++++ b/drivers/pci/host/Makefile
@@ -20,6 +20,7 @@ obj-$(CONFIG_PCIE_ALTERA) += pcie-altera
obj-$(CONFIG_PCIE_ALTERA_MSI) += pcie-altera-msi.o
obj-$(CONFIG_PCIE_ROCKCHIP) += pcie-rockchip.o