aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-06-20 10:49:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-06-20 12:53:37 +0200
commitfa1ee2bd2b8281450a95f4e8eefae3290ae17cac (patch)
treebfa4d238c256873e49832d5d0502965bf6390d50
parent076ea9f473198363d2bd4b4702c4922ab9c9fafa (diff)
downloadupstream-fa1ee2bd2b8281450a95f4e8eefae3290ae17cac.tar.gz
upstream-fa1ee2bd2b8281450a95f4e8eefae3290ae17cac.tar.bz2
upstream-fa1ee2bd2b8281450a95f4e8eefae3290ae17cac.zip
kernel: Add CONFIG_RTC to generic config
RTC (the legacy driver) should not really be used, but seems to crop up after the kernel update. Fix this by disabling it in the generic config. Fixes the following build issue seen in arm64 or powerpc64: ARM JTAG DCC console (HVC_DCC) [N/y/?] n Virtio console (VIRTIO_CONSOLE) [N/m/y/?] n Enhanced Real Time Clock Support (legacy PC RTC driver) (RTC) [N/m/y/?] (NEW) aborted! Console input/output is redirected. Run 'make oldconfig' to update configuration. scripts/kconfig/Makefile:37: recipe for target 'silentoldconfig' failed This should fix the build on the arm64/generic and the layerscape/64b targets. Fixes: 6c5c3a2edccf ("kernel: Update to version 4.4.182") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/arc770/config-4.42
-rw-r--r--target/linux/archs38/config-4.42
-rw-r--r--target/linux/generic/config-4.42
3 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/arc770/config-4.4 b/target/linux/arc770/config-4.4
index f484de30be..d89d839506 100644
--- a/target/linux/arc770/config-4.4
+++ b/target/linux/arc770/config-4.4
@@ -64,7 +64,6 @@ CONFIG_GENERIC_IO=y
CONFIG_GENERIC_IRQ_CHIP=y
CONFIG_GENERIC_IRQ_SHOW=y
CONFIG_GENERIC_SMP_IDLE_THREAD=y
-# CONFIG_GEN_RTC is not set
CONFIG_GPIOLIB=y
CONFIG_GPIO_DEVRES=y
CONFIG_GPIO_DWAPB=y
@@ -154,7 +153,6 @@ CONFIG_RCU_STALL_COMMON=y
CONFIG_REGMAP=y
CONFIG_REGMAP_MMIO=y
CONFIG_RESET_CONTROLLER=y
-# CONFIG_RTC is not set
# CONFIG_SCHED_INFO is not set
# CONFIG_SCSI_DMA is not set
CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
diff --git a/target/linux/archs38/config-4.4 b/target/linux/archs38/config-4.4
index a09c7c4b61..269cd95ef0 100644
--- a/target/linux/archs38/config-4.4
+++ b/target/linux/archs38/config-4.4
@@ -70,7 +70,6 @@ CONFIG_GENERIC_IRQ_CHIP=y
CONFIG_GENERIC_IRQ_SHOW=y
CONFIG_GENERIC_PENDING_IRQ=y
CONFIG_GENERIC_SMP_IDLE_THREAD=y
-# CONFIG_GEN_RTC is not set
CONFIG_GPIOLIB=y
CONFIG_GPIO_DEVRES=y
CONFIG_GPIO_DWAPB=y
@@ -166,7 +165,6 @@ CONFIG_REGMAP_MMIO=y
CONFIG_RESET_CONTROLLER=y
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
-# CONFIG_RTC is not set
# CONFIG_SCHED_INFO is not set
# CONFIG_SCSI_DMA is not set
CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
diff --git a/target/linux/generic/config-4.4 b/target/linux/generic/config-4.4
index 997d332061..38f423c994 100644
--- a/target/linux/generic/config-4.4
+++ b/target/linux/generic/config-4.4
@@ -1200,6 +1200,7 @@ CONFIG_GENERIC_NET_UTILS=y
# CONFIG_GENERIC_PHY is not set
# CONFIG_GENEVE is not set
# CONFIG_GENWQE is not set
+# CONFIG_GEN_RTC is not set
# CONFIG_GFS2_FS is not set
# CONFIG_GIGASET_CAPI is not set
# CONFIG_GIGASET_DEBUG is not set
@@ -3183,6 +3184,7 @@ CONFIG_RFKILL=y
# CONFIG_RPCSEC_GSS_KRB5 is not set
# CONFIG_RPR0521 is not set
# CONFIG_RT2X00 is not set
+# CONFIG_RTC is not set
# CONFIG_RTC_CLASS is not set
# CONFIG_RTC_DEBUG is not set
# CONFIG_RTC_DRV_ABB5ZES3 is not set