aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-10-06 23:46:38 +0200
committerJohn Crispin <john@phrozen.org>2016-10-18 09:18:55 +0200
commitf5aa4590433638e6b2c191412fa802ae5a64cdc9 (patch)
tree731058742aa98d85eec3184545fae87374ba8492
parent6bb11d52f3ae8ce8aa0a270c6ae305809af8b7ce (diff)
downloadupstream-f5aa4590433638e6b2c191412fa802ae5a64cdc9.tar.gz
upstream-f5aa4590433638e6b2c191412fa802ae5a64cdc9.tar.bz2
upstream-f5aa4590433638e6b2c191412fa802ae5a64cdc9.zip
ar71xx: Add support to TP-Link EAP120
Signed-off-by: Henryk Heisig <hyniu@o2.pl>
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh7
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/ar71xx/config-4.43
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-eap120.c126
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/tp-link.mk15
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c101
11 files changed, 269 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index f720767fbb..b7b91d0ad8 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -66,6 +66,7 @@ ar71xx_setup_interfaces()
bullet-m|\
c-55|\
cap4200ag|\
+ eap120|\
eap300v2|\
eap7660d|\
el-mini|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 0d069ec88c..7a40f44e4a 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -130,6 +130,9 @@ get_status_led() {
oolite)
status_led="$board:red:system"
;;
+ eap120)
+ status_led="$(ar71xx_board_name):green:system"
+ ;;
eap300v2)
status_led="engenius:blue:power"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 940c1c95de..1492b50774 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -361,6 +361,9 @@ tplink_pharos_board_detect() {
'CPE520(TP-LINK|UN|N300-5)')
model='TP-Link CPE520'
;;
+ 'EAP120(TP-LINK|UN|N300-2)')
+ model='TP-Link EAP120'
+ ;;
esac
[ -n "$model" ] && AR71XX_MODEL="$model v$2"
@@ -563,6 +566,10 @@ ar71xx_board_detect() {
*"Domino Pi")
name="gl-domino"
;;
+ *"EAP120")
+ name="eap120"
+ tplink_pharos_board_detect
+ ;;
*"EAP300 v2")
name="eap300v2"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 7c554e3f29..35e9bb4391 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -433,7 +433,8 @@ platform_check_image() {
return $?
;;
cpe210|\
- cpe510)
+ cpe510|\
+ eap120)
tplink_pharos_check_image "$1" && return 0
return 1
;;
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index fb59b077ce..77a594999d 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -80,6 +80,7 @@ CONFIG_ATH79_MACH_DLAN_PRO_500_WP=y
CONFIG_ATH79_MACH_DR344=y
CONFIG_ATH79_MACH_DR531=y
CONFIG_ATH79_MACH_DRAGINO2=y
+CONFIG_ATH79_MACH_EAP120=y
CONFIG_ATH79_MACH_EAP300V2=y
CONFIG_ATH79_MACH_EAP7660D=y
CONFIG_ATH79_MACH_EL_M150=y
@@ -315,7 +316,9 @@ CONFIG_LEDS_NU801=y
# CONFIG_LEDS_WNDR3700_USB is not set
CONFIG_LIBFDT=y
CONFIG_MARVELL_PHY=y
+CONFIG_MDIO_BITBANG=y
CONFIG_MDIO_BOARDINFO=y
+CONFIG_MDIO_GPIO=y
CONFIG_MICREL_PHY=y
CONFIG_MIPS=y
CONFIG_MIPS_CLOCK_VSYSCALL=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 3084155673..7c171ee2ac 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -666,6 +666,15 @@ config ATH79_MACH_GL_INET
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_EAP120
+ bool "TP-LINK EAP120 support"
+ select SOC_AR934X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_EAP300V2
bool "EnGenius EAP300 v2 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index ed5c4d8faf..c528c03e35 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -86,6 +86,7 @@ obj-$(CONFIG_ATH79_MACH_DLAN_PRO_500_WP) += mach-dlan-pro-500-wp.o
obj-$(CONFIG_ATH79_MACH_DR344) += mach-dr344.o
obj-$(CONFIG_ATH79_MACH_DR531) += mach-dr531.o
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
+obj-$(CONFIG_ATH79_MACH_EAP120) += mach-eap120.o
obj-$(CONFIG_ATH79_MACH_EAP300V2) += mach-eap300v2.o
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
obj-$(CONFIG_ATH79_MACH_EL_M150) += mach-el-m150.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-eap120.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-eap120.c
new file mode 100644
index 0000000000..130c7706a6
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-eap120.c
@@ -0,0 +1,126 @@
+/*
+ * TP-LINK EAP120 board support
+ *
+ * Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/platform_data/mdio-gpio.h>
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <linux/platform_data/phy-at803x.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+#define EAP120_GPIO_LED_RED 12
+#define EAP120_GPIO_LED_YEL 13
+#define EAP120_GPIO_LED_GRN 15
+#define EAP120_GPIO_BTN_RESET 4
+
+#define EAP120_KEYS_POLL_INTERVAL 20 /* msecs */
+#define EAP120_KEYS_DEBOUNCE_INTERVAL (3 * EAP120_KEYS_POLL_INTERVAL)
+
+#define EAP120_GPIO_SMI_MDIO 16
+#define EAP120_GPIO_SMI_MDC 17
+
+#define EAP120_LAN_PHYADDR 4
+
+static struct gpio_led eap120_leds_gpio[] __initdata = {
+ {
+ .name = "eap120:red:system",
+ .gpio = EAP120_GPIO_LED_RED,
+ .active_low = 1,
+ }, {
+ .name = "eap120:yellow:system",
+ .gpio = EAP120_GPIO_LED_YEL,
+ .active_low = 1,
+ }, {
+ .name = "eap120:green:system",
+ .gpio = EAP120_GPIO_LED_GRN,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button eap120_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = EAP120_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = EAP120_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+static struct mdio_gpio_platform_data eap120_mdio = {
+ .mdc = EAP120_GPIO_SMI_MDC,
+ .mdio = EAP120_GPIO_SMI_MDIO,
+ .phy_mask = ~BIT(EAP120_LAN_PHYADDR),
+};
+
+static struct at803x_platform_data eap120_ar8035_data = {
+ .disable_smarteee = 0,
+ .enable_rgmii_rx_delay = 1,
+ .enable_rgmii_tx_delay = 0,
+ .fixup_rgmii_tx_delay = 1,
+};
+
+static struct platform_device eap120_phy_device = {
+ .name = "mdio-gpio",
+ .id = 0,
+ .dev = {
+ .platform_data = &eap120_mdio, &eap120_ar8035_data
+ },
+};
+
+static void __init eap_setup(u8 *mac)
+{
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(eap120_leds_gpio),
+ eap120_leds_gpio);
+
+ ath79_register_gpio_keys_polled(1, EAP120_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(eap120_gpio_keys),
+ eap120_gpio_keys);
+
+ ath79_register_m25p80(NULL);
+
+ /* MDIO Interface */
+ platform_device_register(&eap120_phy_device);
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0);
+
+ /* GMAC0 is connected to the RGMII interface to an Atheros AR8035-A */
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_eth0_data.mii_bus_dev = &eap120_phy_device.dev;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(EAP120_LAN_PHYADDR);
+ ath79_eth0_pll_data.pll_1000 = 0x0e000000;
+ ath79_eth0_pll_data.pll_100 = 0x00000101;
+ ath79_eth0_pll_data.pll_10 = 0x00001313;
+ ath79_register_eth(0);
+}
+
+static void __init eap120_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f030008);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ eap_setup(mac);
+
+ ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_EAP120, "EAP120", "TP-LINK EAP120",
+ eap120_setup);
+
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 8835b97bd0..aa8215bbeb 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -75,6 +75,7 @@ enum ath79_mach_type {
ATH79_MACH_DR344, /* Wallys DR344 */
ATH79_MACH_DR531, /* Wallys DR531 */
ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
+ ATH79_MACH_EAP120, /* TP-LINK EAP120 */
ATH79_MACH_EAP300V2, /* EnGenius EAP300 v2 */
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
ATH79_MACH_EL_M150, /* EasyLink EL-M150 */
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index c4cd25ffb8..3559555985 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -109,6 +109,21 @@ $(Device/cpe510-520)
endef
TARGET_DEVICES += cpe210-220 cpe510-520
+define Device/eap120
+ DEVICE_TITLE := TP-LINK EAP120
+ MTDPARTS := spi0.0:128k(u-boot)ro,64k(pation-table)ro,64k(product-info)ro,1536k(kernel),14336k(rootfs),192k(config)ro,64k(ART)ro,15872k@0x40000(firmware)
+ IMAGE_SIZE := 15872k
+ BOARDNAME := EAP120
+ TPLINK_BOARD_NAME := EAP120
+ DEVICE_PROFILE := EAP120
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | patch-cmdline | lzma | loader-kernel
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += eap120
+
define Device/tl-wdr4300-v1
$(Device/tplink-8mlzma)
DEVICE_TITLE := TP-LINK TL-WDR4300 v1
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 4938f74eec..fdf93d75d5 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -108,6 +108,9 @@ static const char cpe510_vendor[] = "CPE510(TP-LINK|UN|N300-5):1.0\r\n";
/** Vendor information for C2600 */
static const char c2600_vendor[] = "";
+/** Vendor information for EAP120 */
+static const char eap120_vendor[] = "EAP120(TP-LINK|UN|N300-2):1.0\r\n";
+
/**
The flash partition table for CPE210/220/510/520;
it is the same as the one used by the stock images.
@@ -162,6 +165,25 @@ static const struct flash_partition_entry c2600_partitions[] = {
{NULL, 0, 0}
};
+/** The flash partition table for EAP120;
+ it is the same as the one used by the stock images.
+*/
+static const struct flash_partition_entry eap120_partitions[] = {
+ {"fs-uboot", 0x00000, 0x20000},
+ {"partition-table", 0x20000, 0x02000},
+ {"default-mac", 0x30000, 0x00020},
+ {"support-list", 0x31000, 0x00100},
+ {"product-info", 0x31100, 0x00100},
+ {"soft-version", 0x32000, 0x00100},
+ {"os-image", 0x40000, 0x180000},
+ {"file-system", 0x1c0000, 0x600000},
+ {"user-config", 0x7c0000, 0x10000},
+ {"backup-config", 0x7d0000, 0x10000},
+ {"log", 0x7e0000, 0x10000},
+ {"radio", 0x7f0000, 0x10000},
+ {NULL, 0, 0}
+};
+
/**
The support list for CPE210/220
*/
@@ -188,6 +210,13 @@ static const char c2600_support_list[] =
"SupportList:\r\n"
"{product_name:Archer C2600,product_ver:1.0.0,special_id:00000000}\r\n";
+/**
+ The support list for EAP120
+*/
+static const char eap120_support_list[] =
+ "SupportList:\r\n"
+ "EAP120(TP-LINK|UN|N300-2):1.0\r\n";
+
#define error(_ret, _errno, _str, ...) \
do { \
fprintf(stderr, _str ": %s\n", ## __VA_ARGS__, \
@@ -514,6 +543,37 @@ static void * generate_sysupgrade_image_c2600(const struct flash_partition_entry
return image;
}
+static void *generate_sysupgrade_image_eap120(const struct flash_partition_entry *flash_parts, const struct image_partition_entry *image_parts, size_t *len)
+{
+ const struct flash_partition_entry *flash_os_image = &flash_parts[6];
+ const struct flash_partition_entry *flash_file_system = &flash_parts[7];
+
+ const struct image_partition_entry *image_os_image = &image_parts[3];
+ const struct image_partition_entry *image_file_system = &image_parts[4];
+
+ assert(strcmp(flash_os_image->name, "os-image") == 0);
+ assert(strcmp(flash_file_system->name, "file-system") == 0);
+
+ assert(strcmp(image_os_image->name, "os-image") == 0);
+ assert(strcmp(image_file_system->name, "file-system") == 0);
+
+ if (image_os_image->size > flash_os_image->size)
+ error(1, 0, "kernel image too big (more than %u bytes)", (unsigned)flash_os_image->size);
+ if (image_file_system->size > flash_file_system->size)
+ error(1, 0, "rootfs image too big (more than %u bytes)", (unsigned)flash_file_system->size);
+
+ *len = flash_file_system->base - flash_os_image->base + image_file_system->size;
+
+ uint8_t *image = malloc(*len);
+ if (!image)
+ error(1, errno, "malloc");
+
+ memset(image, 0xff, *len);
+ memcpy(image, image_os_image->data, image_os_image->size);
+ memcpy(image + flash_file_system->base - flash_os_image->base, image_file_system->data, image_file_system->size);
+
+ return image;
+}
/** Generates an image for CPE210/220/510/520 and writes it to a file */
static void do_cpe(const char *output,
@@ -588,6 +648,45 @@ static void do_c2600(const char *output, const char *kernel_image, const char *r
}
+/** Generates an image for EAP120 and writes it to a file */
+static void do_eap(const char *output,
+ const char *kernel_image,
+ const char *rootfs_image,
+ uint32_t rev,
+ bool add_jffs2_eof,
+ bool sysupgrade,
+ const char *support_list) {
+ struct image_partition_entry parts[6] = {};
+
+ parts[0] = make_partition_table(eap120_partitions);
+ parts[1] = make_soft_version(rev);
+ parts[2] = make_support_list(support_list, false);
+ parts[3] = read_file("os-image", kernel_image, false);
+ parts[4] = read_file("file-system", rootfs_image, add_jffs2_eof);
+
+ size_t len;
+ void *image;
+ if (sysupgrade)
+ image = generate_sysupgrade_image_eap120(eap120_partitions, parts, &len);
+ else
+ image = generate_factory_image(eap120_vendor, parts, &len);
+
+ FILE *file = fopen(output, "wb");
+ if (!file)
+ error(1, errno, "unable to open output file");
+
+ if (fwrite(image, len, 1, file) != 1)
+ error(1, 0, "unable to write output file");
+
+ fclose(file);
+
+ free(image);
+
+ size_t i;
+ for (i = 0; parts[i].name; i++)
+ free_image_partition(parts[i]);
+}
+
/** Usage output */
static void usage(const char *argv0) {
fprintf(stderr,
@@ -673,6 +772,8 @@ int main(int argc, char *argv[]) {
do_cpe(output, kernel_image, rootfs_image, rev, add_jffs2_eof, sysupgrade, cpe510_support_list);
else if (strcmp(board, "C2600") == 0)
do_c2600(output, kernel_image, rootfs_image, rev, add_jffs2_eof, sysupgrade);
+ else if (strcmp(board, "EAP120") == 0)
+ do_eap(output, kernel_image, rootfs_image, rev, add_jffs2_eof, sysupgrade, eap120_support_list);
else
error(1, 0, "unsupported board %s", board);