aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarl Vogel <karl.vogel@gmail.com>2018-11-29 09:07:21 +0100
committerJo-Philipp Wich <jo@mein.io>2018-11-29 11:37:04 +0100
commitecf104c023b82a364e8e41b4e26312a8601cffc6 (patch)
treecf72288b177e1a4ad9e214f949083478c40504f4
parent6cf22507fd6ccfa2f1006e91d7f060301a3b78f5 (diff)
downloadupstream-ecf104c023b82a364e8e41b4e26312a8601cffc6.tar.gz
upstream-ecf104c023b82a364e8e41b4e26312a8601cffc6.tar.bz2
upstream-ecf104c023b82a364e8e41b4e26312a8601cffc6.zip
sdk: find kernel modules when KDIR is a symlink
The find statement would not return any results if the KDIR_BASE pointed to a symlink. Ran into this issue due to a custom Kernel/Prepare that was installing a symlink to the kernel directory. The extra slash at the end fixes this scenario and does no harm for targets that have a proper KDIR. Signed-off-by: Karl Vogel <karl.vogel@gmail.com> (cherry picked from commit ae980458abf8299d614f4b34add32e18d054378d)
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index ae4bce5260..7fd8547228 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -82,7 +82,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
$(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
- `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+ `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \
`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
-type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \