aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-10-20 00:00:39 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-10-20 00:00:39 +0000
commite73c42876f33fb8b29c5c42eeb2d967b52bf028a (patch)
treec5d20011c97cceef7c46caaf918f99424843c770
parentfb152a810c1aed05cd4ad5fb90bd9c378aec60c3 (diff)
downloadupstream-e73c42876f33fb8b29c5c42eeb2d967b52bf028a.tar.gz
upstream-e73c42876f33fb8b29c5c42eeb2d967b52bf028a.tar.bz2
upstream-e73c42876f33fb8b29c5c42eeb2d967b52bf028a.zip
kernel: force CONFIG_BT_HCIUART_ATH3K to y
The CONFIG_BT_HCIUART_ATH3K may not be "m", therfore we cannot inherit the kmod selection state. Force the "CONFIG_BT_HCIUART_ATH3K" symbol to "y" in order to avoid `warning: symbol value 'm' invalid for BT_HCIUART_ATH3K` and subsequent kconfig stalls. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 47237
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9ff291dd0f..022410f2be 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -84,7 +84,7 @@ define KernelPackage/ath3k
DEPENDS:=+kmod-bluetooth +ar3k-firmware
KCONFIG:= \
CONFIG_BT_ATH3K \
- CONFIG_BT_HCIUART_ATH3K
+ CONFIG_BT_HCIUART_ATH3K=y
$(call AddDepends/bluetooth)
FILES:= \
$(LINUX_DIR)/drivers/bluetooth/ath3k.ko