aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus <k-laus@quantentunnel.de>2016-07-24 17:37:52 +0200
committerJohn Crispin <john@phrozen.org>2016-10-04 11:50:51 +0200
commitdf5416296cda4f7338a3d6eea361f8e8c8d667c6 (patch)
treeaa4cedd15b42e8628eab4426dc99c44ead9c03ad
parenta79f3d11b3d7e4441544a2401f129bd055e84034 (diff)
downloadupstream-df5416296cda4f7338a3d6eea361f8e8c8d667c6.tar.gz
upstream-df5416296cda4f7338a3d6eea361f8e8c8d667c6.tar.bz2
upstream-df5416296cda4f7338a3d6eea361f8e8c8d667c6.zip
ramips: add support for Zyxel NBG-419N2 (WAP3205v2)
applied bb-final-ramips-add-zyxel-nbg-419n2.patch from 123serge123, found at https://yadi.sk/d/1ZV0lKJwbTE65; see https://forum.openwrt.org/viewtopic.php?pid=246905#p246905, modified slightly to fit to CC release and to new lede build system: image/rt305x.mk include file is used now changed NBG-419N2.dts format to fit style of other dts files Signed-off-by: Klaus <k-laus@quantentunnel.de>
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/NBG-419N2.dts117
-rw-r--r--target/linux/ramips/image/rt305x.mk8
6 files changed, 134 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 52119383b0..e3b2177820 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -234,6 +234,10 @@ mzk-ex750np)
na930)
set_usb_led "$board:blue:status"
;;
+nbg-419n2)
+ set_usb_led "$board:green:usb"
+ set_wifi_led "rt2800pci-phy0::radio"
+ ;;
newifi-d1)
set_usb_led "$board:red:status"
;;
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 98afa05e04..2f092b0bca 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -27,6 +27,7 @@ get_status_led() {
mzk-dp150n|\
mzk-w300nh2|\
nbg-419n|\
+ nbg-419n2|\
pwh2004|\
wnce2001|\
wndr3700v5|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 9c6c3b10dd..d57c1cf922 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -325,6 +325,9 @@ ramips_board_detect() {
*"NBG-419N")
name="nbg-419n"
;;
+ *"NBG-419N v2")
+ name="nbg-419n2"
+ ;;
*"Newifi-D1")
name="newifi-d1"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index e6c7845e5b..b90a591ded 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -96,6 +96,7 @@ platform_check_image() {
mzk-w300nh2|\
mzk-wdpr|\
nbg-419n|\
+ nbg-419n2|\
newifi-d1|\
nixcore|\
nw718|\
diff --git a/target/linux/ramips/dts/NBG-419N2.dts b/target/linux/ramips/dts/NBG-419N2.dts
new file mode 100644
index 0000000000..981b4e5872
--- /dev/null
+++ b/target/linux/ramips/dts/NBG-419N2.dts
@@ -0,0 +1,117 @@
+/dts-v1/;
+
+#include "rt3352.dtsi"
+
+/ {
+ compatible = "NBG-419N2", "ralink,rt3352-soc";
+ model = "ZyXEL NBG-419N v2";
+
+ palmbus@10000000 {
+ spi@b00 {
+ status = "okay";
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l6405d";
+ reg = <0 0>;
+ linux,modalias = "m25p80", "mx25l6405d";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ power {
+ label = "nbg-419n2:green:power";
+ gpios = <&gpio0 9 1>;
+ };
+
+ wps {
+ label = "nbg-419n2:green:wps";
+ gpios = <&gpio0 14 1>;
+ };
+
+ usb {
+ label = "nbg-419n2:green:usb";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
+ };
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x211>;
+ };
+ rfkill {
+ label = "rfkill";
+ linux,input-type = <5>;
+ gpios = <&gpio0 12 0>;
+ linux,code = <0xf7>;
+ };
+ };
+
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&esw {
+ ralink,portmap = <0x2f>;
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index be21ac47b9..835cb3548f 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -286,6 +286,14 @@ endef
TARGET_DEVICES += nbg-419n
+define Device/nbg-419n2
+ DTS := NBG-419N2
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := ZyXEL NBG-419N2
+endef
+TARGET_DEVICES += nbg-419n2
+
+
define Device/mzk-wdpr
DTS := MZK-WDPR
DEVICE_TITLE := Planex MZK-WDPR