aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-02-23 22:59:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-02-23 22:59:57 +0000
commitc5a65a03735d00b756ad580d4ef829716295ff6a (patch)
treea17428d44645b810e6ace913f48df1eaeedeecfe
parent3edf9c354421445cfe5a8a5cf99d1bfcf57bee94 (diff)
downloadupstream-c5a65a03735d00b756ad580d4ef829716295ff6a.tar.gz
upstream-c5a65a03735d00b756ad580d4ef829716295ff6a.tar.bz2
upstream-c5a65a03735d00b756ad580d4ef829716295ff6a.zip
Send ipkg-make-index.sh output to stdout
The "Generating index for package" created by ipkg-make-index only clutter stderr and serve to push previous warnings/errors off-screen. Instead, send to stdout. Note: This would send incorrect invocation messages to stdout as well. If this is a concern, perhaps we could send them to FD 3, then send 3 to 2... Signed-off-by: Kevin Locke <klocke@digitalenginesoftware.com> SVN-Revision: 25678
-rw-r--r--package/Makefile2
-rw-r--r--target/imagebuilder/files/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 8e8c6c9a63..2180df3b37 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -89,7 +89,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
$(call mklibs)
$(curdir)/index: FORCE
- @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz \
)
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 1fa074b35e..002274acaf 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -112,7 +112,7 @@ package_index: FORCE
@echo
@echo Building package index...
@mkdir -p $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR)/tmp
- (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz \
) >/dev/null 2>/dev/null
$(OPKG) update