aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-09-16 16:27:37 -0700
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:33:33 +0100
commit9cf371c1f42e31cb6bbb2d6cff1308f978ee61ee (patch)
tree9f2e5bf367b24cdcc2fbce36c7d9f4b63f1fca82
parent2f80d846389790b2e47ea156094f90131de26104 (diff)
downloadupstream-9cf371c1f42e31cb6bbb2d6cff1308f978ee61ee.tar.gz
upstream-9cf371c1f42e31cb6bbb2d6cff1308f978ee61ee.tar.bz2
upstream-9cf371c1f42e31cb6bbb2d6cff1308f978ee61ee.zip
dnsmasq: Pass TARGET_CPPFLAGS to Makefile
With the introduction of the ubus notifications, we would now fail building dnsmasq with external toolchains that don't automatically search for headers. Pass TARGET_CPPFLAGS to the Makefile to resolve that. Fixes: 34a206bc1194 ("dnsmasq: add ubus notifications for new leases") Signed-off-by: Florian Fainelli <f.fainelli@gmail.com> (cherry picked from commit ef485bb23d207e0b1031d264a6fafce01d2bdf8f)
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index fe6a6d2fed..01c7191192 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -137,7 +137,7 @@ endif
MAKE_FLAGS := \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
COPTS="$(COPTS)" \
PREFIX="/usr"